hdu1263水果(map容器的嵌套)

题目链接

http://acm.hdu.edu.cn/showproblem.php?pid=1263

水果

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4471    Accepted Submission(s): 1673


Problem Description
夏天来了~~好开心啊,呵呵,好多好多水果~~
Joe经营着一个不大的水果店.他认为生存之道就是经营最受顾客欢迎的水果.现在他想要一份水果销售情况的明细表,这样Joe就可以很容易掌握所有水果的销售情况了.
 

Input
第一行正整数N(0<N<=10)表示有N组测试数据.
每组测试数据的第一行是一个整数M(0<M<=100),表示工有M次成功的交易.其后有M行数据,每行表示一次交易,由水果名称(小写字母组成,长度不超过80),水果产地(小写字母组成,长度不超过80)和交易的水果数目(正整数,不超过100)组成.
 

Output
对于每一组测试数据,请你输出一份排版格式正确(请分析样本输出)的水果销售情况明细表.这份明细表包括所有水果的产地,名称和销售数目的信息.水果先按产地分类,产地按字母顺序排列;同一产地的水果按照名称排序,名称按字母顺序排序.
两组测试数据之间有一个空行.最后一组测试数据之后没有空行.
 

Sample Input
   
   
   
   
1 5 apple shandong 3 pineapple guangdong 1 sugarcane guangdong 1 pineapple guangdong 3 pineapple guangdong 1
 

Sample Output
   
   
   
   
guangdong |----pineapple(5) |----sugarcane(1) shandong |----apple(3)
 
只能说nap太强大了。。学会了map的新用法。。涨姿势
#include<iostream>
#include<map>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{

    int T,m;
    cin>>T;

    while(T--){
        int num;
        string place,name;
        map<string,map<string,int> >mp;
        cin>>m;
        for(int i=0;i<m;i++)
        {
            cin>>name;
            cin>>place;
            cin>>num;
            mp[place][name]+=num;
        }
    for(map<string,map<string,int> >::iterator it=mp.begin();it!=mp.end();it++)

    {
        cout<<it->first<<endl;
        for(map<string,int>::iterator its=it->second.begin();its!=it->second.end();its++)
            cout<<"   |----"<<its->first<<"("<<its->second<<")"<<endl;
    }
    if(T) cout<<endl;
    }

}



你可能感兴趣的:(HDU)