Time Limit: 1000MS Memory Limit: 10000K
Description
Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.
Input
The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.
Output
For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.
Sample Input
5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2
Sample Output
4
题目链接:POJ-1274
题目大意:有n头牛,m种stalls。一头牛对应一种stalls,同样,一种stalls对应一头牛。给出每头牛所能接受的stalls,问最多能满足几头牛
题目思路:很裸的模板题。
二分图最大匹配模板:
const int N = 300;
char map[N][N];
int col[N][N],row[N][N];
int link[N],head[N];
bool vis[N];
int cnt,n,m;
int R,C; //两种物品的数量
struct Edge
{
int to;
int next;
};
Edge edge[N*N];
void Init() //初始化
{
cnt = 0;
memset(head,-1,sizeof(head));
memset(col,0,sizeof(col));
memset(row,0,sizeof(row));
}
void add(int u,int v) //u和v相连
{
edge[cnt].to = v;
edge[cnt].next = head[u];
head[u] = cnt++;
}
bool dfs(int u)
{
for(int i=head[u]; ~i; i=edge[i].next)
{
int v = edge[i].to;
if(!vis[v])
{
vis[v] = 1;
if(link[v] == -1 || dfs(link[v]))
{
link[v] = u;
return true;
}
}
}
return false;
}
int match() //直接调用
{
int ans = 0;
memset(link,-1,sizeof(link));
for(int i=1; i<=R; i++)
{
memset(vis,0,sizeof(vis));
if(dfs(i)) ans++;
}
return ans;
}
以下是代码:
#include <iostream>
#include <cmath>
#include <cstring>
#include <string>
#include <cstdio>
using namespace std;
const int N = 300;
char map[N][N];
int col[N][N],row[N][N];
int link[N],head[N];
bool vis[N];
int cnt,n,m;
int R,C;
struct Edge
{
int to;
int next;
};
Edge edge[N*N];
void Init()
{
cnt = 0;
memset(head,-1,sizeof(head));
memset(col,0,sizeof(col));
memset(row,0,sizeof(row));
}
void add(int u,int v)
{
edge[cnt].to = v;
edge[cnt].next = head[u];
head[u] = cnt++;
}
bool dfs(int u)
{
for(int i=head[u]; ~i; i=edge[i].next)
{
int v = edge[i].to;
if(!vis[v])
{
vis[v] = 1;
if(link[v] == -1 || dfs(link[v]))
{
link[v] = u;
return true;
}
}
}
return false;
}
int match()
{
int ans = 0;
memset(link,-1,sizeof(link));
for(int i=1; i<=R; i++)
{
memset(vis,0,sizeof(vis));
if(dfs(i)) ans++;
}
return ans;
}
int main(){
while(cin >> R >> C) //各自数量
{
Init(); //初始化
for (int i = 1; i <= R; i++)
{
int s;
cin >> s;
for (int j = 0; j < s; j++)
{
int a;
cin >> a;
add(i,a); //加入关系
}
}
cout << match() << endl;
}
}