hdu4734(数位dp)

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3530    Accepted Submission(s): 1317


Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
 

Sample Input
   
   
   
   
3 0 100 1 10 5 100
 

Sample Output
   
   
   
   
Case #1: 1 Case #2: 2 Case #3: 13

题意:找出i在0到b之间的f(i)小于等于f(a)的数的个数。

思路:数位dp。主要在于状态转移不好想。dp[i][j]表示i位数比j小的数的个数。用递归完成的话就只需要思考边界和状态转移。

边界:

dp[i][j]如果j小于0,显然是dp[i][j]=0的,如果i==0,说明就是0,显然任何数都比0大,所以dp[i][j]对于j>=0的时候dp[i][j]=1,否则dp[i][j]=0

状态转移:

dp[i][j]+=dp[i-1][j-k*(1<<(i-1))];

完成上述两步推导就能开始写这题了。

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<stack>
using namespace std;
typedef long long ll;
int dp[20][9300];
int digit[20];
int dfs(int pos,int st,bool limit)
{
    if(pos==0)return st>=0;
    if(st<0)return 0;
    if(!limit&&dp[pos][st]!=-1)return dp[pos][st];
    int ans=0;
    int end=limit?digit[pos]:9;
    for(int i=0; i<=end; i++)
        ans+=dfs(pos-1,st-i*(1<<(pos-1)),limit&&(i==end));
    if(!limit)
        dp[pos][st]=ans;
    return ans;
}
int f(int x)
{
    int ans=0;
    int i=0;
    while(x)
        ans+=(x%10)*(1<<(i++)),x/=10;
    return ans;
}
int get(int a,int b)
{
    int bj=0;
    while(b)
        digit[++bj]=b%10,b/=10;
    return dfs(bj,f(a),1);
}
int main()
{
    int t,o=1;
    memset(dp,-1,sizeof(dp));
    scanf("%d",&t);
    while(t--)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        printf("Case #%d: %d\n",o++,get(a,b));
    }
    return 0;
}


你可能感兴趣的:(dp,ACM,大二)