hdu2602(01背包)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 47758    Accepted Submission(s): 19921


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
   
   
   
   
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
   
   
14

题意:

输入n和v,分别输入n个val[i]和n个cost[i],求容量为v的背包能换取多少价值。

思路:

裸的01背包,用dp[i][j]表示选第i个物体的时候价值为j的最大价值。不过写这题的过程中还是要思路清晰,状态转移方程容易写错。

如果我们的容量够拿下第i个物品:dp[i][j]=max(dp[i-1][j],dp[i-1][j-cost[i]]+val[i];

如果我们拿不下第i个物品了:dp[i][j]=dp[i-1][j];


#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<stack>
using namespace std;
typedef long long ll;
int val[1010],cost[1010],dp[1010][1010];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,v;
        scanf("%d%d",&n,&v);
        for(int i=1; i<=n; i++)
            scanf("%d",&val[i]);
        for(int i=1; i<=n; i++)
            scanf("%d",&cost[i]);
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
            for(int j=0; j<=v; j++)
                if(j-cost[i]>=0)
                    dp[i][j]=max(dp[i-1][j],dp[i-1][j-cost[i]]+val[i]);
                else
                    dp[i][j]=dp[i-1][j];
        printf("%d\n",dp[n][v]);
    }
    return 0;
}

然后用01背包的优化,开成一维数组:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<stack>
using namespace std;
typedef long long ll;
int val[1010],cost[1010],dp[1010];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,v;
        scanf("%d%d",&n,&v);
        for(int i=1; i<=n; i++)
            scanf("%d",&val[i]);
        for(int i=1; i<=n; i++)
            scanf("%d",&cost[i]);
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
            for(int j=v; j>=cost[i]; j--)
                dp[j]=max(dp[j],dp[j-cost[i]]+val[i]);
        printf("%d\n",dp[v]);
    }
    return 0;
}


你可能感兴趣的:(dp,ACM,大二)