ZOJ-3329-One Person Game【7th浙江省赛】【概率dp】

ZOJ-3329-One Person Game

            Time Limit: 1 Second      Memory Limit: 32768 KB      Special Judge

There is a very simple and interesting one-person game. You have 3 dice, namely Die1, Die2 and Die3. Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1, K2, K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

Set the counter to 0 at first.
Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
If the counter’s number is still not greater than n, go to step 2. Otherwise the game is ended.
Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers n, K1, K2, K3, a, b, c (0 <= n <= 500, 1 < K1, K2, K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input
2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output
1.142857142857143
1.004651162790698

题目链接:ZOJ-3329

题目大意:有三个骰子,分别有k1,k2,k3个面。 每次掷骰子,如果三个面分别为a,b,c则分数置0,否则加上三个骰子的分数之和。
当分数大于n时结束。求游戏的期望步数。初始分数为0。

题目思路:(感觉这类题目还是想不通。。(ಥ _ ಥ))

假设dp[i]表示拥有分数i到游戏结束的期望步数

则dp[i]=SUM(p[k]*dp[i+k])+p[0]*dp[0]+1; //p[k]表示增加分数为k的概率,p[0]表示分数变为0的概率 ①

假定 dp[i]=A[i]*dp[0]+B[i]; ②

则 dp[i+k]=A[i+k]*dp[0]+B[i+k]; ③

将③代入①得: (4):dp[i]=(SUM(p[k]*A[i+k])+p[0])*dp[0]+SUM(p[k]*B[i+k])+1; ④

将4与2做比较得:

A[i]=(SUM(p[k]*A[i+k])+p[0]);

B[i]=SUM(p[k]*B[i+k])+1;

当i+k>n时A[i+k]=B[i+k]=0可知

所以dp[0]=B[0]/(1-A[0])可求出

参考博客:here

以下是代码:

#include <bits/stdc++.h>
using namespace std;
double p[500];
int main(){
    int t;
    cin >> t;
    while(t--)
    {
        int n,k1,k2,k3,a,b,c;
        cin >> n >> k1 >> k2 >> k3 >> a >> b >> c;
        int ks = k1 * k2 * k3;
        double p0 = 1.0 / ks;
        memset(p,0,sizeof(p));
        for (int i = 1; i <= k1; i++)
        {
            for (int j = 1; j <= k2; j++)
            {
                for (int k = 1; k<= k3; k++)
                {
                    p[i + j + k] += p0;
                }
            }
        }
        p[a + b + c] -= p0; //注意减去等于a,b,c的情况
        double x[1000] = {0},y[1000] = {0};
        for (int i = n; i >= 0; i--)
        {
            for (int k = 3; k <= ks && (i + k) <= n; k++)
            {
                x[i] += x[i + k] * p[k];
                y[i] += y[i + k] * p[k];
            }
            x[i] += p0;
            y[i] += 1;
        }
        printf("%.15lf\n", y[0]/(1 - x[0]));
    } 
    return 0;
}





你可能感兴趣的:(dp,ZOJ,3329)