1408111555-hd-FatMouse' Trade.cpp

                                     FatMouse' Trade

                                              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                               Total Submission(s): 43146    Accepted Submission(s): 14413


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
   
   
   
   
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
   
   
   
   
13.333 31.500
 
题目大意
      老鼠拿着粮食去跟猫交换,老鼠有n粮食,有m个房间,每个房间的老鼠的粮食和猫需要的都不一样,但是都是等比例交换,也就是在每个房间老鼠拿着(猫所需粮)*a%可以换(房间内鼠粮)*a%,要求老鼠可以换到的最多的粮食数量。
解题思路
      很明显需要用到贪心,将兑换比例做降序排列,然后依次兑换直到老鼠手里没粮食为止。
代码
#include<stdio.h>
#include<algorithm>
using namespace std;
struct food
{
    int j;
    int f;
    double h;
}foods[1100];
bool cmp(food a,food b)
{
    return a.h>b.h;
}
int main()
{
    int n,m;
    int i,k;
    double sum;
    while(scanf("%d%d",&n,&m),n!=-1||m!=-1)
    {
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&foods[i].j,&foods[i].f);
            foods[i].h=foods[i].j/(foods[i].f*1.0);
        }
        sort(foods,foods+m,cmp);
        sum=0;
        for(i=0;i<m;i++)
        {
            if(n>foods[i].f)
            {
                n-=foods[i].f;
                sum+=foods[i].j;
            }
            else
            {
                sum+=n*foods[i].j/(foods[i].f*1.0);
                n=0;
            }
            if(n==0)
                break;
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}


你可能感兴趣的:(1408111555-hd-FatMouse' Trade.cpp)