Billboard
Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17087 Accepted Submission(s): 7219
Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.
On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.
Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.
When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.
If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).
Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases).
The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.
Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
Sample Input
Sample Output
题意:有一个h*w的公告牌,有n个公告要贴在上面,每个公告条面积为1*wi,依次从上往下,从左往右贴公告条。按公告条给出的顺序贴。问这些公告条分别被贴在哪一行? 没有合适位置贴的公告输出-1。
题解:我们建立一棵线段树,假设i表示的区间为[L,R](L表示第L行,R表示第R行),则maxv[i]的值表示在区间[L,R]内单行剩余空间的最大值。 这样我们维护的线段树区间最大为min(h,n)。 现在我们依次输入wi,线段树维护的信息是在区间[L,R]中单行剩余空间的最大值。如果maxv[i]>=w,则说明这个区间内有一行能放下wi,再优先往左查询(题目要求公告牌上部有空间就放在上部)。 这棵线段树中不需要query(),我们可以直接在update中更新区间时,返回查找到的行数。
代码如下:
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 200020
#define lson i*2,l,m
#define rson i*2+1,m+1,r
using namespace std;
int maxv[maxn*4],id[maxn*4];
int h,w,n,m,cnt;
void PushUp(int i)
{
maxv[i]=max(maxv[i*2],maxv[i*2+1]);
}
void build(int i,int l,int r)
{
if(l==r)
{
maxv[i]=w;
id[i]=++cnt;
return ;
}
int m=(l+r)/2;
build(lson);
build(rson);
PushUp(i);
}
int update(int wi,int i,int l,int r)
{
if(wi>maxv[i])
return -1;
if(l==r)//找到最合适的行放下wi
{
maxv[i]-=wi;
return id[i];
}
int ans=-1;
int m=(l+r)/2;
if(maxv[i*2]>=wi)
ans=update(wi,lson);
else if(maxv[i*2+1]>=wi)
ans=update(wi,rson);
PushUp(i);
return ans;
}
int main()
{
while(scanf("%d%d%d",&h,&w,&n)!=EOF)
{
cnt=0;
m=min(h,n);//线段树的叶节点最大数目
build(1,1,m);
while(n--)
{
int wi;
scanf("%d",&wi);
printf("%d\n",update(wi,1,1,m));
}
}
return 0;
}