POJ 1753 Flip Game(bfs)

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

POJ 1753 Flip Game(bfs)_第1张图片Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4
我为了方便,把二维数组转化成一维数组来表示状态。然后用x表示到达的点,ans表示已翻过的棋子数,a表示棋盘布局。然后用bfs搜索。
#include <stdio.h>
#include <string.h>
struct node
{
    int a[20];
    int x;
    int ans;
} q[1000000];
void bfs(int map[])
{
    node f1, f2;
    int s=0, e=0, i, j;
    for(i=0; i<16; i++)
    {
        f1.a[i]=map[i];
    }
    f1.x=0;
    f1.ans=0;
    q[s++]=f1;
    while(s>e)
    {
        f1=q[e++];
        /*printf("%d\n",e);
        printf("%d\n",f1.ans);
        for(i=0; i<16; i++)
            printf("%d ",f1.a[i]);
        printf("\n");
        if(e>=4)
            break;*/
        int ss=0;
        for(i=0; i<16; i++)
        {
            ss+=f1.a[i];
        }
        if(ss==0||ss==16)//判断是否全白或全黑
        {
            printf("%d\n",f1.ans);
            return ;
        }
        for(i=0; i<16; i++)
        {
            if(f1.x<=i)
            {
                for(j=0; j<16; j++)
                {
                    f2.a[j]=f1.a[j];
                }
                if(i-4>=0)
                    f2.a[i-4]=1-f1.a[i-4];//反转上面
                if(i%4)
                    f2.a[i-1]=1-f1.a[i-1];//反转左边
                if(i+4<=15)
                    f2.a[i+4]=1-f1.a[i+4];//反转下边
                if((i+1)%4)
                    f2.a[i+1]=1-f1.a[i+1];//反转右边
                f2.a[i]=1-f1.a[i];//反转当前棋子
                f2.ans=f1.ans+1;
                f2.x=i+1;
                q[s++]=f2;
            }
        }
    }
    printf("Impossible\n");
    return ;
}
int main()
{
    int i, j, map[20];
    char s[20];
    for(i=0; i<4; i++)
    {
        scanf("%s",s);
        for(j=0; j<4; j++)
        {
            if(s[j]=='b')
                map[4*i+j]=1;
            else
                map[4*i+j]=0;
        }
    }
    bfs(map);
    return 0;
}


你可能感兴趣的:(编程,算法,C语言,poj,bfs)