数据结构实验之链表一:顺序建立链表

题目描述

输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。

输入

第一行输入整数的个数N;
第二行依次输入每个整数。

输出

输出这组整数。

示例输入

8
12 56 4 6 55 15 33 62

示例输出

12 56 4 6 55 15 33 62

提示

#include <stdio.h>
#include <stdlib.h>
using namespace std;

struct node
{
    int n;
    struct node *next;
}*head;
int main()
{
    int n, i;
    scanf("%d",&n);
    head = new node;
    head ->next = NULL;
    node *q = head;
    for(i = 0; i <n; i++)
    {
        node *p = new node;
        scanf("%d",&p->n);
        p ->next = NULL;
        q -> next = p;
        q = p;
    }
    for(node *a=head->next; a !=NULL; a= a->next)
    {
        printf("%d ", a->n);
    }
    return 0;
}


你可能感兴趣的:(编程,C语言)