【POJ 1286】Necklace of Beads(polya定理)

【POJ 1286】Necklace of Beads(polya定理)

Necklace of Beads
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 7550   Accepted: 3145

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 
【POJ 1286】Necklace of Beads(polya定理)_第1张图片

Input

The input has several lines, and each line contains the input data n. 
-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39

Source

Xi'an 2002

polya裸题,。教程翻烂了百度,全是那么一套……然而没太明白,请教QAQ巨稍微理解了点,。

题目说旋转和对称算同种,所以枚举所有旋转和对称步数,然后套公式……


代码如下:

#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define Pr pair<int,int>
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout)

using namespace std;
const int INF = 0x3f3f3f3f;
const int msz = 32768;
const int mod = 1e9+7;
const double eps = 1e-8;

int main()
{
    int n;
    LL ans;

    while(~scanf("%d",&n) && n != -1)
    {
        if(!n)
        {
            puts("0");
            continue;
        }
        ans = 0;
        for(int i = 1; i <= n; ++i)
            ans += pow(3.0,__gcd(n,i));

        if(n&1) printf("%lld\n",(ans+(LL)pow(3.0,1+n/2)*n)/(n*2));
        else printf("%lld\n",(ans+(LL)pow(3.0,n/2)*(n/2)+(LL)pow(3.0,2+(n-2)/2)*(n/2))/(2*n));
    }

    return 0;
}




你可能感兴趣的:(【POJ 1286】Necklace of Beads(polya定理))