2016SDAU课程练习一_1013

Problem Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

题目大意

每一次交连续5个月的报表。每次交都是亏损(一开始想每次都亏一年必定亏啊,然而并不是)。

只要保证在交报表的时候其中一个月的亏损大于剩下四个月的盈利。只要让第一次亏损出现在五月,就能保证连续提交的5次都是亏损。同理在十月份亏损一次,就能保证连续8次(主要是因为一年只有12个月才会出现8次。如果一年13个月就会出现9次)都亏损。这是在某一次亏损非常严重的情况。
如果某次的亏损并不像上述情况这么严重,那么至少每五个月中亏损两次才能保证连续亏损。那么就让第四五次亏损,同理第九、十次也要亏损。

现在知道亏损的月份和亏损的money多少。就可以算出最大盈利了

#include <iostream> 
using namespace std;  

int main()  
{  
    int s,d;  
    int res;  
    while(cin>>s && cin>>d)  
    {  
        if(d>4*s)res=10*s-2*d;  
        else if(2*d>3*s)res=8*s-4*d;  
        else if(3*d>2*s)res=6*(s-d);  
        else if(4*d>s)res=3*(s-3*d);  
        else res=-1;  
        if(res<0)cout<<"Deficit"<<endl;  
        else cout<<res<<endl;  
    }  
    return 0;  
}  

你可能感兴趣的:(2016SDAU课程练习一_1013)