1038. Recover the Smallest Number (30)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

#include <iostream>
#include <fstream>
#include <algorithm>
#include <string>
using namespace std;

bool cmp(const string& A,const string& B) {
    return A+B < B+A;
}

int main() {
    int n;
    cin>>n;
    int i;
    string* num = new string[n];
    for(i=0;i<n;i++) {
        cin>>num[i];
    }
    sort(num,num+n,cmp);
    string ss;
    for(i=0;i<n;i++)
        ss = ss+num[i];
    const char* ch = ss.c_str();
    i=0;
    while(ch[i]=='0') {
        i++;
    }
    ch = ch + i;
    if(ch[0]=='\0')
        cout<<0<<endl;
    else
        cout<<ch<<endl;
    return 0;
}

你可能感兴趣的:(1038. Recover the Smallest Number (30))