129 - Krypton Factor

Krypton Factor

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequence of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called “easy”. Other sequences will be called “hard”.

For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are:

BB
ABCDACABCAB
ABCDABCD 

Some examples of hard sequences are:

D
DC
ABDAB
CBABCBA 

Input and Output

In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines that contain integers n and L (in that order), where n > 0 and L is in the range 1L26 , and for each input line prints out the nth hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is A. You may assume that for given n and L there do exist at least n hard sequences.

For example, with L = 3, the first 7 hard sequences are:

A
AB
ABA
ABAC
ABACA
ABACAB
ABACABA 

As each sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.

Therefore, if the integers 7 and 3 appear on an input line, the output lines produced should be

ABAC ABA
7

Input is terminated by a line containing two zeroes. Your program may assume a maximum sequence length of 80.

Sample Input

30 3
0 0

Sample Output

ABAC ABCA CBAB CABA CABC ACBA CABA
28

如果一个字符串包含两个相邻的重复子串,则称它是“容易的串”,其他串称为“困难的串”。例如,BB、ABCDACABCAB、ABCDABCD都是容易的串,而D、DC、ABDAB、CBABCBA都是困难的串。

输入正整数n和L,输出由前L个字符组成的、字典序第k小的困难的串。例如,当L=3时,前7个困难的串分别为A、AB、ABA、ABAC、ABACA、ABACAB、ABACABA。输入保证答案不超过80个字符。

样例输入:

7 3
30 3

样例输出:

ABACABA
ABACABCACBABCABACABCACBACABA

//#define LOCAL
#include <iostream>
#include <cstdio>

using namespace std;
// n为第几个困难串,L为字符个数
int n, L;
// 当前是第几个困难串
int cnt;

const int maxNum = 105;
// 标记位置
int S[maxNum];

// 深搜和回溯法
int dfs(int cur) {
    // 递归出口
    if(cnt++ == n) {
        // 输出
        if(cur <= 4) {
            for(int i = 0; i < cur; i++) {
                printf("%c", 'A' + S[i]);
            }
        } else {
            for(int i = 0; i < 4; i++) {
                printf("%c", 'A' + S[i]);
            }
            for(int i = 4; i < cur; i++) {
                if(i % (16 * 4) == 0) {
                    printf("\n");
                } else if(i % 4 == 0) {
                    printf(" ");
                }
                printf("%c", 'A' + S[i]);
            }
        }
        printf("\n%d\n", cur);
        return 0;
    } else {
        for(int i = 0; i < L; i++) {
            S[cur] = i;
            int ok = 1;
            // 后缀最长不超过当前总长度的1/2
            for(int j = 1; j * 2 <= cur + 1; j++) {
                int equals = 1;
                for(int k = 0; k < j; k++) {
                    // 检测后一半是否能与前一半
                    if(S[cur - k] != S[cur - k - j]) {
                        equals = 0;
                        break;
                    }
                }
                // 后一半等于前一半,该方案不合法
                if(equals) {
                    ok = 0;
                    break;
                }
            }
            if(ok) {
                // 递归搜索,找到解则退出
                if(!dfs(cur + 1)) {
                    return 0;
                }
            }
        }
    }
    return 1;
}

int main() {
    #ifdef LOCAL
        freopen("data.129.in", "r", stdin);
        freopen("data.129.out", "w", stdout);
    #endif // LOCAL
    while(cin >> n >> L) {
        if(!n) {
            break;
        }
        cnt = 0;
        dfs(0);
    }
    return 0;
}

你可能感兴趣的:(ACM,uva,UVa129)