1009. Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6


#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;

double input1[1001];
double input2[1001];
double result[2003];

int main() {
    int k, exp, i, j;
    double coef; 
    while(cin>>k) {
        int count = 0;
        while(k--) {
            cin>>exp>>coef;
            input1[exp] += coef;
        }
        cin>>k;
        while(k--) {
            cin>>exp>>coef;
            input2[exp] += coef;
        }

        for(i=0; i<=1000; i++) {
            for(j=0; j<=1000; j++) {
                result[i+j] += input1[i]*input2[j];
            }
        }

        for(i=0; i<=2000; i++) {
            if(fabs(result[i]) > 1e-6 ) {
                count++;
            }
        }
        cout<<count;
        for(i=2000; i>=0; i--) {
            if(fabs(result[i]) > 1e-6) {
                printf(" %d %.1lf", i, result[i]);
            }
        }
        cout<<endl;
    }
    return 0;
} 


你可能感兴趣的:(C++,pat)