组合数学:C -- Simple Addition Expression

A luxury yacht with 100 passengers on board is sailing on the sea in the twilight. The yacht is ablaze with lights and there comes out laughers and singing from the hall where an evening party is in full swing. People are singing, dancing and enjoying themselves. 

The yacht is equipped with the most advanced navigation and driving system which can all be manipulated by a computer. When the captain notices that there is only gentle breeze and the sea waves are not high, he starts the autopilot. The yacht sails forward smoothly, ploughs the waves. When it’s completely dark, the passengers start to feel a little funny for sudden forward rushes or sudden decelerations or slight swings. The captain immediately walks to the driving platform and switches the autopilot to human manipulation. The yacht returns back to normal and the party restarts. Laughers come back, too. 

The captain summons the engineer on board to do a thorough check of the navigation system. It turns out that only the computer is out of order, but the exact failure is still unclear. There is a computer scientist among the passengers who is also invited to the cab to give a hand. He first inputs several groups of data to test the computer. When he inputs 1+2+3, the computer outputs 6, which is exactly right. But when he inputs 4+5+6, the computer outputs 5, which is wrong. Then he inputs 12+13+14, and gets 39, another right answer, while he inputs 14+15+16, and gets 35, another wrong answer. After the test, the computer scientist says smilingly: “the failure is clear now. The computer's adder can not carry." After excluding the failure, the captain restarts the autopilot and the yacht returns back to normal, sailing smoothly on the sea. 

The captain and the engineer invite the computer scientist to sit down and have a talk. The computer scientist tells a story as following: 

A former mathematician defined a kind of simple addition expression. 
If there is an expression (i) + (i+1) + (i+2), i>=0, when carried out additive operations, no position has a carry, it is called simple addition expression. 

For instance, when i equals 0, 0+1+2 is a simple addition expression, meanwhile when i equals 11, 11+12+13 is a simple addition expression, too. Because of that no position has a carry. 

However, when i equals 3, 3+4+5 is not a simple addition expression, that is because 3+4+5 equals 12, there is a carried number from unit digit to tens digit. In the same way, when i equals 13, 13+14+15 is not a simple addition expression, either. However, when i equals 112, 112+113+114 is a simple addition expression. Because 112+113+114 equals 339, there is no carry in the process of adding. 

when the students have got the definition of simple addition expression, the mathematician puts forward a new question: for a positive integer n, how many simple addition expressions exist when i<n. In addition, i is the first number of a simple addition expression. 

when the value of n is large enough, the problem needs to be solved by means of computer. 

 

Input

There are several test cases, each case takes up a line, there is an integer n (n<10^10). 

 

Output

Output the number of all simple addition expressions when i<n. 

 

Sample Input

     
     
     
     
1 2 3 4 10 11
 

Sample Output

     
     
     
     
1 2 3 3 3 4

思路:这题刚开始看不太明白题目讲的是什么意思,不知道那简单的加法是什么意思,然后看别人的博客,原来意思就是这几个数相加,每位数都不进位的属于题目所讲的简单加法……

然后又研究了好一会才知道什么解,个位数不能超过2,其他位数不超过3即可:即个位最大为3,其他位最大为4.把这个数当做字符串就好解决了,从这个字符串的第一位开始判断就可以了……然后计算这些排列数就行了。如果为个数,就直接加上,如果有其他位数,那先判断第一位,如果大于3就可以直接用相乘,如果小于3的话,那这位数之前的可以直接相乘,这位数的情况就往下位数继续判断……这样依次判断到最后个位数就行了……把这些结果相加就得到结果了。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<vector>
#include<stack>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long ll;
int main()
{
    char a[20];
    while(cin>>a)
    {
        int i,sum=0,l=strlen(a),c;
        for(i=0; i<l; i++)
        {
            c=a[i]-'0';
            if(i==l-1)
            {
                if(c<3) sum+=c;
                else sum+=3;
                break;
            }
            if(c<4) sum+=c*pow(4.0,l-i-2)*3;
            else
            {
                sum+=pow(4.0,l-i-1)*3;
                break;
            }
        }

        cout<<sum<<endl;
    }
    return 0;
}


你可能感兴趣的:(组合数学:C -- Simple Addition Expression)