POJ-1961 Period-KMP前缀串重复次数

Period
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 14803   Accepted: 7054

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source

Southeastern Europe 2004

/*    
*Copyright (c)2015,烟台大学计算机与控制工程学院    
*All rights reserved.      
*作    者:单昕昕    
*完成日期:2015年8月25日    
*版 本 号:v1.0        
*/ 
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxw=1000000+10;
char a[maxw];
int next[maxw];
int main()
{
    int n,i,t=1;
    while(cin>>n&&n!=0)
    {
        scanf("%s",a);
        next[0]=-1;
        next[1]=0;
        int p=0;
        printf("Test case #%d\n",t++);
        for(i=2; i<=n; i++)
        {
            while(p>=0&&a[p]!=a[i-1]) p=next[p];
            next[i]=++p;
            int count=i/(i-next[i]);
            if(i%(i-next[i])==0&&next[i]!=0)//i-next[i]为循环节长度
            {
                printf("%d %d\n",i,count);
            }
        }
        putchar('\n');
    }
    return 0;
}


你可能感兴趣的:(C++,poj)