POJ-2739 Sum of Consecutive Prime Numbers-求一个数满足有多少组递增相加的素数等于该数

Sum of Consecutive Prime Numbers
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 20975   Accepted: 11513

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

Source

Japan 2005

//求一个数满足有多少组递增相加的素数等于该数
#include <iostream>
using namespace std;
const int maxp=2000,n=10000;
int prime[maxp],total=0;

bool isprime(int k)
{
    int i;
    for(i=0; i<total; ++i)
        if(k%prime[i]==0)
            return false;
    return true;
}

int main()
{
    int i,j,m,cnt,ans;
    for(i=2; i<=n; ++i)//先打表,把所有的素数枚举出来
        if(isprime(i))
            prime[total++]=i;
    prime[total]=n+1;
    cin>>m;
    while(m)
    {
        ans=0;
        for(i=0; m>=prime[i]; ++i)
        {
            cnt=0;
            for(j=i; j<total&&cnt<m; ++j)
                cnt+=prime[j];
            if(cnt==m)
                ++ans;
        }
        cout<<ans<<endl;
        cin>>m;
    }
    return 0;
}


你可能感兴趣的:(C++,poj)