POJ 2406 Power Strings:KMP算法

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed。

思路:用KMP算法,但是刚开始不知道怎么判断重复多少次,所以写出了那个next的每个值了才知道怎么判断。
#include <iostream>
#include <map>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
char s[1000005];
int next[1000005],len;
int getnext()
{
    int k = -1,j = 0,x;
    next[0] = -1;
    while(j < len)
    {
        if(k == -1 ||s[j] == s[k]) next[++j] = ++k;
        else k = next[k];
    }
    x=j-next[j];   //或者可以写成x=len-k;都一样的
    if(len%x==0) return len/x;
    return 1;
}
int main()
{
    while(scanf("%s",s)&&s[0]!='.')
    {
        len=strlen(s);
        printf("%d\n",getnext());
    }
    return 0;
}

你可能感兴趣的:(POJ 2406 Power Strings:KMP算法)