POJ 1118 Lining Up(枚举)

 Lining Up
Time Limit:2000MS    Memory Limit:32768K
Total Submissions: 24910           Accepted:7809


Description

"How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?


Your program has to be efficient!
Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.
Output

output one integer for each input case ,representing the largest number of points that all lie on one line.
Sample Input

5
1 1
2 2
3 3
9 10
10 11
0
Sample Output

3
Source

East Central North America 1994


题意:

       给出n个点,求最多有几个点共线,,,,

思路:

       枚举即可,,一开始想到的是先根据任意两点枚举所有直线,然后判断有多少点在直线上,,,那么求直线需要两层循环,求在直线上点的个数又要嵌套一层循环,这样的话可能会超时,,

       先从第一个点开始扫,求后边的点与第一个点的斜率,统计相同斜率的个数,,,

然后从第二个点扫,再统计斜率的个数,,,

最后排序判断那个最多。。。

此处注意qsort对double 的排序,,,cmp函数需要重写。。。

以下AC代码:

#include<stdio.h>
#include<math.h>
#include<stdlib.h>
int cmp(const void *a,const void *b)
{
    return *(double *)a>*(double *)b?1:-1;
}
int a[705],b[705];
double s[10000];
int main()
{
    int i,j,k;
    int n;
    int max;
    while(scanf("%d",&n),n)
    {
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&a[i],&b[i]);
        }
        int index;
        max=0;
        for(i=0;i<n;i++)
        {
            index=0;
            for(j=i+1;j<n;j++)
            {
                s[index++]=(b[j]-b[i])*1.0/(a[j]-a[i])*1.0;
            }
            qsort(s,index,sizeof(s[0]),cmp);
            int count=1;
            for(k=1;k<index;k++)
            {
                if(s[k]==s[k-1])
                {
                    count++;
                }
            }
            if(count>max)
                max=count;
        }
        printf("%d\n",max+1);
    }
    return 0;
}

你可能感兴趣的:(POJ 1118 Lining Up(枚举))