Smallest Difference(枚举)

Smallest Difference
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3973   Accepted: 1110

Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0. 

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.

Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.

Sample Input

1
0 1 2 4 6 7

Sample Output

28

 

      题意:

      给出 T 个 case,后给出 2 到 10 个数,数字由递增顺序给出。将这些数凑成两个数,求绝对值最小值。

 

      思路:

      暴力枚举。运用 next_permutation 不断生成序列即可。给出的数没有固定给出多少个,所以用字符串保存再转成数字。注意不能有前导 0 的生成数。

 

      AC:

#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <cstdlib>

using namespace std;

int num[15], ans;
char str[30];

int main() {
        int t;
        scanf("%d", &t);

        getchar();

        while (t--) {
                ans = 0;

                gets(str);

                for (int i = 0; i < strlen(str); ++i) {
                        if (str[i] >= '0' && str[i] <= '9')
                                num[ans++] = str[i] - '0';
                }

                sort(num, num + ans);

                int Min = 999999999;
                do {
                        if ((!num[0] || !num[ans / 2]) && ans > 2) continue;

                        int a = 0, b = 0;
                        for (int i = 0; i < ans; ++i) {
                                if (i < ans / 2) a = a * 10 + num[i];
                                else b = b * 10 + num[i];
                        }

                        Min = min(Min, abs(a - b) );

                } while(next_permutation(num, num + ans));

                printf("%d\n", Min);
        }

        return 0;
}

 

 

你可能感兴趣的:(diff)