JOJ ACM 1149

Given a positive integer n, nd the positions of all 1's in its binary representation. The position of the least significant bit is 0.



Example
The positions of 1's in the binary representation of 13 are 0, 2, 3.




Task
Write a program which for each data set:


reads a positive integer n,

computes the positions of 1's in the binary representation of n,

writes the result.



Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.




Output
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.


Sample Input
1
13
Sample Output
0 2 3
code:
#include<iostream>
#include<vector>
using namespace std;

void main()
{
	int d,num;
	cin>>d;
	while(d!=0)
	{
	  vector<int> v;
           cin>>num;
	  while(num!=0)
	  {
                  v.push_back(num%2);
		num/=2;
	  }
	  for(int i=0;i<v.size();i++)
	  {
		  if(v[i]==1)
		  {
		    if(i!=v.size()-1)
		       cout<<i<<" ";
                       else
		       cout<<i<<endl;
		  }
	  }
	  d--;
	}
}

你可能感兴趣的:(ACM)