题目:HDU 1003 Max Sum
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
/*最大连续最大子段和
* 参数:
* a[] 输入数组
* n 数组元素个数
* start, end 返回的最大子段和的起始和结束位置
*/
int maxsum(int a[], int n, int &start, int &end)
{
int tmp = a[0];
int max = a[0];
int i, tmpstart = 0, tmpend = 0;
start = 1;
end = 1;
for(i = 1; i < n; i++)
{
if(tmp >= 0) //可以是>0 也可以是>=0,看怎么要求
{
tmp += a[i];
tmpend = i;
}
else
{
tmp = a[i];
tmpstart = i;
tmpend = i;
}
if(max < tmp)
{
start = tmpstart + 1;
end = tmpend + 1;
max = tmp;
}
}
return max;
}
int main()
{
int tc, n, tmp;
int start, end;
int max;
int i, j;
int a[100001];
scanf("%d", &tc);
for(j = 0; j < tc; j++)
{
scanf("%d", &n);
for( i = 0; i < n; i++)
scanf("%d", &a[i]);
max = maxsum(a, n, start, end);
printf("Case %d:\n", j + 1);
printf("%d %d %d\n", max, start, end);
if(j != tc - 1)
printf("\n");
}
return 0;
}