Least Common Multiple
http://acm.hdu.edu.cn/showproblem.php?pid=1019
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
105
10296
解题思路
经典的最大公约数(gcd)和最小公倍数(lcm)题目。
这两个算法是代码模块。
注意:
先除后乘防止数据溢出!!
#include <stdio.h>
#include <stdlib.h>
int gcd(int a, int b)
{
if (b == 0) {
return a;
} else {
return gcd(b, a % b);
}
}
int lcm(int a, int b)
{
int g;
g = gcd(a, b);
return a / g * b;
}
int main (int argc, char const* argv[])
{
int c, n, i, ans, t;
scanf("%d", &c);
while (c--) {
scanf("%d", &n);
scanf("%d", &ans);
for (i = 1; i < n; i++) {
scanf("%d", &t);
ans = lcm(ans, t);
}
printf("%d\n", ans);
}
return 0;
}