BGP RR 路由反射器实验
关键字
BGP RR 路由反射器 BGP属性
拓朴
实验说明
  配置使用BGP路由反射器
配置
R1 的配置
!
hostname R1
!
interface Loopback1
ip address 11.11.11 .1 255.255.255.0
!
interface Serial2/1
ip address 112.10.10.1 255.255.255.0
serial restart-delay 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 11.11.11.0 mask 255.255.255.0
neighbor 112.10.10.2 remote-as 234

no auto-summary
!
您现在所查看的文档出自西安深度 3G 网络工程师培训[url]www.norvel.com.cn[/url]
R2 的配置
!
hostname R2
!
interface Serial2/1
ip address 112.10.10.2 255.255.255.0
serial restart-delay 0
!
interface Serial2/2
ip address 123.10.10.2 255.255.255.0
serial restart-delay 0
!
router bgp 234
no synchronization
bgp log-neighbor-changes
neighbor 112.10.10.1 remote-as 100
neighbor 123.10.10.3 remote-as 234
neighbor 123.10.10.3 next-hop-self

no auto-summary
!
您现在所查看的文档出自西安深度 3G 网络工程师培训[url]www.norvel.com.cn[/url]
R3 的配置
!
hostname R3
!
interface Serial2/1
ip address 123.10.10.3 255.255.255.0
serial restart-delay 0
!
interface Serial2/2
ip address 134.10.10.3 255.255.255.0
serial restart-delay 0
!
router bgp 234
no synchronization
bgp log-neighbor-changes
neighbor 123.10.10.2 remote-as 234
neighbor 123.10.10.2 route-reflector-client
neighbor 134.10.10.4 remote-as 234
neighbor 134.10.10.4 route-reflector-client

no auto-summary
!
您现在所查看的文档出自西安深度 3G 网络工程师培训[url]www.norvel.com.cn[/url]
R4 的配置
!
hostname R4
!
interface Serial2/1
ip address 134.10.10.4 255.255.255.0
serial restart-delay 0
!
interface Serial2/2
ip address 145.10.10.4 255.255.255.0
serial restart-delay 0
!
router bgp 234
no synchronization
bgp log-neighbor-changes
neighbor 134.10.10.3 remote-as 234
neighbor 134.10.10.3 next-hop-self
neighbor 145.10.10.5 remote-as 500

no auto-summary
!
您现在所查看的文档出自西安深度 3G 网络工程师培训[url]www.norvel.com.cn[/url]
R5 的配置
!
hostname R5
!
interface Loopback1
ip address 55.55.55.5 255.255.255.0
!
interface Serial2/2
ip address 145.10.10.5 255.255.255.0
serial restart-delay 0
!
router bgp 500
no synchronization
bgp log-neighbor-changes
network 55.55.55.0 mask 255.255.255.0
neighbor 145.10.10.4 remote-as 234

no auto-summary
!
 
 
 
调试
进行调试
R2#show ip bgp
BGP table version is 2, local router ID is 123.10.10.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.11.11 .0/24 112.10.10.1 0 0 100 i
* i55.55.55.0/24 134.10.10.4 0 100 0 500 i
R3#show ip bgp
BGP table version is 7, local router ID is 134.10.10.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i 11.11.11 .0/24 123.10.10.2 0 100 0 100 i
*>i55.55.55.0/24 134.10.10.4 0 100 0 500 i
R4#show ip bgp
BGP table version is 2, local router ID is 135.10.10.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
* i 11.11.11 .0/24 123.10.10.2 0 100 0 100 i
*> 55.55.55.0/24 145.10.10.5 0 0 500 i