Week 1 - Basic

第一周 数据结构与算法的关系

【主要考察:复杂度】

题1:最大子列和问题

给定K个整数组成的序列{ N1, N2, ..., NK },“连续子列”被定义为{ Ni, Ni+1, ..., Nj },其中 1 <= i <= j <= K。“最大子列和”则被定义为所有连续子列元素的和中最大者。例如给定序列{ -2, 11, -4, 13, -5, -2 },其连续子列{ 11, -4, 13 }有最大的和20。现要求你编写程序,计算给定整数序列的最大子列和。

输入格式:
输入第1行给出正整数 K (<= 100000);第2行给出K个整数,其间以空格分隔。
输出格式:
在一行中输出最大子列和。如果序列中所有整数皆为负数,则输出0。
输入样例:
6
-2 11 -4 13 -5 -2
输出样例:
20

解决思路:

  1. 暴力枚举。O(N^3);
  2. 动态规划。O(N);

算法优化的本质:减少重复计算,减少不必要的计算。

import java.util.Scanner;

public class MaxSubseqSum {
    private static int getMaxSubSum(int[] list, int N) 
    {
        int thisSum=0, maxSum=0;
        for(int i = 0; i < N; i++)
        {
            thisSum += list[i];
            if (thisSum > maxSum)
                maxSum = thisSum;
            else if (thisSum < 0)
                thisSum = 0;
        }
        return maxSum;
    }
        
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        while (in.hasNext())
        {
            int N = in.nextInt();
            int i = 0;
            int[] list = new int[N];
            while (i < N)
                list[i++] = in.nextInt();
        
            int result = getMaxSubSum(list, N);
            System.out.println(result);
        }
    }
}

题2:Maximum Subsequence Sum

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

**Sample Input: **
10
-10 1 2 3 4 -5 -23 3 7 -21
**Sample Output: **
10 1 4

解决思路:

  1. 这道题比前面要求多了一条,不仅要返回最大子列和,还要告诉子序列首尾的index。关键在于什么时候修改首位的index,什么时候修改末位的index。
  2. 还要特别注意特殊输入(0,负数,和为0等等)
import java.util.Scanner;

public class MaxSubseqSumV2 {   
    private static int[] getMaxSubSum(int[] list, int N) 
    {
        int thisSum=0, maxSum=-1;
        int tempIndex=0, leftIndex=0, rightIndex=0;
        for(int i = 0; i < N; i++)
        {
            thisSum += list[i];
            if (thisSum > maxSum)
            {
                maxSum = thisSum;
                leftIndex = tempIndex;
                rightIndex = i;
            }
            else if (thisSum < 0)
            {
                thisSum = 0;
                tempIndex = i+1;
            }
        }
        
        int[] result = new int[3];
        result[1] = list[leftIndex];
        if (maxSum == -1){
            result[0] = 0;
            result[2] = list[N-1];
        }
        else {
            result[0] = maxSum;
            result[2] = list[rightIndex];
        }
        return result;
    }
    
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        while (in.hasNext())
        {
            int N = in.nextInt();
            int i = 0;
            int[] list = new int[N];
            while (i < N)
                list[i++] = in.nextInt();
        
            int[] result = getMaxSubSum(list, N);
            System.out.println(result[0] + " " + result[1] + " " + result[2]);
        }
    }
}

你可能感兴趣的:(Week 1 - Basic)