PAT 1058 A+B in Hogwarts python解法

1058 A+B in Hogwarts (20 分)
If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,107​ ], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

解题思路:这个题类似人民币的加法,比如4元5角6分+5元6角7分=10元2角3分,人民币的加法是逢十进一,而此题是Knut(就是人民币中的分)逢29进1,Sickle(就是人民币中的角)逢17进1,Galleon就是正常的相加。首先先把输入转成int型的2个列表,然后从最后一项开始相加,相加时进行判断是否需要进位,如果需要进位就相加取余,同时在前一项上加1,不需要进位则直接加起来。

a, b = input().split()
#a, b = '3.2.1', '10.16.27'
a = a.split('.')
b = b.split('.')
a = [int(i) for i in a]
b = [int(i) for i in b]

if a[2]+b[2] < 29: 
    a[2] = a[2]+b[2]
else:
    a[2] = (a[2]+b[2])%29
    a[1] += 1
if a[1]+b[1] < 17: 
    a[1] = a[1]+b[1]
else:
    a[1] = (a[1]+b[1])%17
    a[0] += 1
a[0] = a[0]+b[0]
a = [str(i) for i in a]
print('.'.join(a))

你可能感兴趣的:(python,用Python刷PAT,(Advanced,Level),Practice)