PAT 1005 Spell It Right python解法

1005 Spell It Right (20 分)
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​ ).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

题意:给你一串数字,求出它们的和,并将结果转换为英文。如:给出12345,求和得15,转为英文为one five。

解题思路:首先扫描输入的数据,把每一个数字加总求和,然后定义一个列表存储0-9的单词,再扫描和中的每一位,将其转换为英文存起来,最后输出结果。

n = input()
sum_ = 0
for i in n:
    sum_ += int(i)
    
d = ['zero', 'one', 'two', 'three', 'four', 'five', 'six', 'seven', 'eight', 'nine']
out = []
for i in str(sum_):
    out.append(d[int(i)])
print(' '.join(out))

你可能感兴趣的:(python,用Python刷PAT,(Advanced,Level),Practice)