蓝桥杯BASIC-13(数列排序)

问题描述
  给定一个长度为n的数列,将这个数列按从小到大的顺序排列。1<=n<=200
输入格式
  第一行为一个整数n。
  第二行包含n个整数,为待排序的数,每个整数的绝对值小于10000。
输出格式
  输出一行,按从小到大的顺序输出排序后的数列。
样例输入
5
8 3 6 4 9
样例输出

package testing_02;

import java.util.Scanner;
import java.util.Arrays;

public class test_13 {
//   public static void Minfy(int[] arr,int i,int n){
//      while(2*i
//          int j=2*i;
//          if((j+1arr[j+1]))
//          {j=j+1;}
//         if(arr[i]>arr[j]){
//          int temp=arr[i];
//          arr[i]=arr[j];
//          arr[j]=temp;
//      }
//      i=j;
//     }
//    }
//   public static void heapsort(int[] arr){
//     int length=arr.length;
//     int i=length/2;
//     for(int k=i;k>=0;k--){
//          sort(arr,k,length-1);          
//     }
//    
//     for(int j=0;j
//         System.out.print(arr[j]+" ");
//     }
//   }
//  public static void main(String[] args) {
//      // TODO Auto-generated method stub
//      Scanner input =new Scanner(System.in);
//      int n=input.nextInt();
//      //String str=input.nextLine();
//      //int[] arr={1,5,4,2,6};
//      int[] arr=new int[n];
//      for(int i=0;i
//        arr[i]=input.nextInt();
//      }
//      heapsort(arr);
//  }



    //public class Main {

    public static void main(String[] args)

    {

    Scanner sc = new Scanner(System.in);

    int n, a[];

    while(sc.hasNextInt()){

    n = sc.nextInt();

    a = new int[n];

    for(int i=0; ifor(int i=0; iout.print(a[i] + " ");

    System.out.println();

    }

    }

    }

你可能感兴趣的:(其他)