今日头条笔试题

 
  
/*
题目描述:
给定两个长度为 n 的整数数列 A 和 B。再给定 q 组查询,每次查询给出两个整数 x 和 y,求满足 Ai >= x 且 Bi >= y 这样的 i 的数量。
输入
第一行给定两个整数 n 和 q。
第二行给定数列 A,包含 n 个整数。
第三行给定数列 B,包含 n 个整数。
接下来 q 行,每行两个整数 x 和 y,意义如上所述。
输出
对于每组查询,输出所求的下标数量。

样例输入
3 2
3 2 4
6 5 8
1 1
4 8
样例输出
3
1
*/


 
  
package com.company;
import java.util.Scanner;

/**
 * Created by zhangheng on 2017/8/22.
 */
public class Index {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int length = sc.nextInt();
        int num = sc.nextInt();
        int arr1[] = new int[length];
        int arr2[] = new int[length];
        int res[] = new int[num];

        for(int i=0;i=arr[0] && arr2[i-1]>=arr[1]){
                    cnt++;

                }
            }

        return cnt;
    }
}

 
  
 
  
 
 

你可能感兴趣的:(JAVA)