sdut 2499 数字

Problem Description
定义f(x) = {比x小,不可以被x整除并且不和x互质的数的个数}(x为正整数)。
当f(x) 是奇数的时候我们称x为“奇真数”。
给出两个数x,y求区间[x,y]内的“奇真数”的个数。

Input
第一行输入一个数N代表测试数据个数(N<=20)。接下来N行每行两个正整数x , y ( 0 < x <= y < 2^31)。

Output
对于每个测试数据输出“奇真数”的个数,每行输出一个结果。

Sample Input
2
1 1
1 10
Sample Output
0
4
Hint
中国海洋大学第三届“朗讯杯”编程比赛高级组试题
Source

import java.util.*;

public class Main{
    public static void main(String[] args){
        Scanner cin = new Scanner(System.in);
        int n = cin.nextInt();
        while ( n!= 0 ){
            long a = cin.nextInt();
            long b = cin.nextInt();
            System.out.println(f(b)-f(a-1));
            n--;
        }
    }
    public static long f(long x){
        if ( x <= (long)2 ){
            return 0;
        }
        return x/2-1+((long)Math.sqrt((long)x*1.0)%2==1?0:-1);
    }
}

你可能感兴趣的:(java)