北大oj-1002 487-3279

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 
 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

分析

题目大意为 先输入电话号码数目,然后输入非格式化的电话号码,统计 每个出现了多少次, 输出重复的。若没有 重复输出No duplicates. 

第一版代码(错误)

想的太简单了,直接用的字符串处理,完全超时。

# include 
# include 
# include 
# include 
using namespace std;
string findnum(string s){
    int n = 0;
    int a = 0;
    int i = 0;
    while(s[i]!='#'){
        switch(s[i]){
        case 'A':
        case 'B':
        case 'C':a = a*10 + 2;break;
        case 'D':
        case 'E':
        case 'F':a = a*10 + 3;break;
        case 'G':
        case 'H':
        case 'I':a = a*10 + 4;break;
        case 'J':
        case 'K':
        case 'L':a = a*10 + 5;break;
        case 'M':
        case 'N':
        case 'O':a = a*10 + 6;break;
        case 'P':
        case 'R':
        case 'S':a = a*10 + 7;break;
        case 'T':
        case 'U':
        case 'V':a = a*10 + 8;break;
        case 'W':
        case 'X':
        case 'Y':a = a*10 + 9;break;
        default:break;
        }
        if(s[i]>='0'&&s[i]<='9')
           a = a*10 + s[i] - 48;
        i++;
     }
     stringstream ss1,ss2;
     ss1<a[j]){
                tt = a[i];
                a[i] = a[j];
                a[j] = tt;
                t = b[i];
                b[i] = b[j];
                b[j] = t;
            }
        }
    }
}
int main(){
    string s[100000];
    int num;
    cin>>num;
    int i,j;
    int k = 0;
    int flag;
    for(i = 0;i>s[i];
        s[i] = s[i] + '#';
        s[i] = findnum(s[i]);
      //  cout<

 

第二版代码(正确) 

换了下存储结构,使用map处理。输入字符串后,现在map中查找,若有则递增计数值,若无则插入。由于map自动按key索引,省去了排序的麻烦。输出时直接输出value>1的即可。

同时也改进了下格式化的代码(直接用字符串就好了,不知道为什么我一开始用整型……大晚上写代码容易不清醒)

# include 
# include 
# include 
# include 
using namespace std;
string findnum(string s){
    int n = 0;
    string a = "";
    int i = 0;
    while(s[i]!='\0'){
        switch(s[i]){
        case 'A':
        case 'B':
        case 'C':a = a + '2';break;
        case 'D':
        case 'E':
        case 'F':a = a + '3';break;
        case 'G':
        case 'H':
        case 'I':a = a + '4';break;
        case 'J':
        case 'K':
        case 'L':a = a + '5';break;
        case 'M':
        case 'N':
        case 'O':a = a + '6';break;
        case 'P':
        case 'R':
        case 'S':a = a + '7';break;
        case 'T':
        case 'U':
        case 'V':a = a + '8';break;
        case 'W':
        case 'X':
        case 'Y':a = a + '9';break;
        default:break;
        }
        if(s[i]>='0'&&s[i]<='9')
           a = a + s[i];
        i++;
     }
     a.insert(3,"-");
     return a;
  //   cout<phone;
    int num;
    cin>>num;
    int i;
    for(i = 0;i>str;
       str = findnum(str);

       map::iterator iter;
       iter = phone.find(str);
       if(iter!=phone.end()) {
            (iter->second)++;
       }
       else {
        phone.insert(pair(str,1));
       // cout<<"insert"<::iterator iter;
    for(iter = phone.begin();iter!=phone.end();iter++){
        if(iter->second > 1){
            cout<first<<" "<second<

 

你可能感兴趣的:(北大oj)