Anniversary party【树形DP】

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14991 Accepted: 8538


Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.


Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output
Output should contain the maximal sum of guests’ ratings.


Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output
5


解题思路
其实就是 没有上司的舞会 由树到图,实际解决思路是一样的,把它看做是一棵有 m m m个节点的“树”再做树形 d p dp dp即可,需要注意的是,这里的是相邻点,所以是具有传递性的,应该建双向边,状态转移方程自然和没有上司的舞会一样.
因为 N N N个点, N − 1 N-1 N1条边,任意两个火车站有且只有一条路径,所以是一棵树
我们用 f [ d e p ] [ 1 ] f[dep][1] f[dep][1]表示在以x为根的树中开饭店, x x x一定要开,所能获得的最大利润, f [ d e p ] [ 0 ] f[dep][0] f[dep][0] 表示在以x为根的树中开饭店, x x x一定不开,所能获得的最大利润,我们知道X开,则它的儿子们 y 1 , … y k y1,…yk y1,yk一定不能开, x x x不开,它的儿子们可开可不开,于是得到以下状态转移方程:

  • f [ d e p ] [ 1 ] + = f [ a [ i ] . x ] [ 0 ] ; f[dep][1]+=f[a[i].x][0]; f[dep][1]+=f[a[i].x][0];
  • f [ d e p ] [ 0 ] + = m a x ( f [ a [ i ] . x ] [ 1 ] , f [ a [ i ] . x ] [ 0 ] ) ; f[dep][0]+=max(f[a[i].x][1],f[a[i].x][0]); f[dep][0]+=max(f[a[i].x][1],f[a[i].x][0]);

实现时用 D F S DFS DFS去实现,每个点只需求一次,所以时间复杂度为 O ( N ) O(N) O(N)


代码

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int n,w[6010],h[6010],v[6010],f[6010][2],x,y,k;
struct c{
	int x,next;
}a[13010];
void add(int x,int y){
	++k;
	a[k].x=y;
	a[k].next=h[x];
	h[x]=k;
}
void dfs(int dep){
	v[dep]=1;
	f[dep][1]=w[dep];
	for(int i=h[dep];i;i=a[i].next)
	{
		if(v[a[i].x])continue;//求过了就不必再求了
		dfs(a[i].x);
		f[dep][1]+=f[a[i].x][0];
		f[dep][0]+=max(f[a[i].x][1],f[a[i].x][0]);
	} 
}
int main(){
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
		scanf("%d",&w[i]);
	for(int i=1;i<=n;i++)
	{
		scanf("%d%d",&x,&y);
		if(x==0&&y==0)break;
		add(x,y);
		add(y,x);//建边
	}
	dfs(1);
	printf("%d",max(f[1][1],f[1][0]));
}

你可能感兴趣的:(树状DP)