杭电acm1026 Ignatius and the Princess I

Ignatius and the Princess I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20281 Accepted Submission(s): 6605
Special Judge

Problem Description

The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a NM two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:
 
1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.
 
Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
 
Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N
M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
 
Output
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
 
Sample Input
5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.
 
Sample Output
It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero.
FINISH

Solution

这道题也是典型的深度搜索问题,要注意的就是在打印结果时从目标节点递归找到起点在依次在退出递归时打印每个节点的信息

Code

package acm1026;
 
/**
 * date:2017.11.30;
 * author:孟小德
 * function: 杭电acm1026  Ignatius and the Princess I
 *      bfs 广度搜索
 */
 
import java.util.*;
 
class Node implements Comparable
{
    public int x,y,step;
    public Node()
    {
 
    }
 
    public int compareTo(Node object)
    {
        return this.step - object.step;
    }
}
 
public class Main
{
    //  四个方向
    public static int[][] dir = {{0,1},{0,-1},{1,0},{-1,0}};
    public static int map[][];
    public static int flag[][];
    public static int blood[][];
    public static int n,m;
 
    public static int judge(int x,int y)
    {
        if (x<0 || x>=n || y<0 || y>=m)
        {
            return 1;
        }
        if (map[x][y] == -1)
        {
            return 1;
        }
        return 0;
    }
 
    public static int BFS()
    {
        PriorityQueue queue = new PriorityQueue();
        Node start = new Node();
        Node next = new Node();
        start.x = 0;
        start.y = 0;
        start.step = 0;
        map[0][0] = -1;
 
        queue.add(start);
        while(queue.isEmpty() == false)
        {
            start = new Node();
            start = queue.poll();
 
            if (start.x == n-1 && start.y == m-1)
            {
                return start.step;
            }
            for (int i=0;i<4;i++)
            {
                next = new Node();
                next.x = start.x + dir[i][0];
                next.y = start.y + dir[i][1];
 
                if (judge(next.x,next.y) == 1)
                {
                    continue;
                }
                next.step = start.step + 1 + map[next.x][next.y];
                flag[next.x][next.y] = i+1;
                map[next.x][next.y] = -1;
                queue.add(next);
            }
        }
        return -1;
    }
 
    public static int temp;
    public static void print(int x,int y)
    {   //  用递归方法顺序输出
        //  外层递归为路径末尾
        int next_x,next_y;
        if (flag[x][y] == 0)
        {
            return;
        }
        next_x = x - dir[flag[x][y] - 1][0];
        next_y = y - dir[flag[x][y] - 1][1];
        print(next_x,next_y);
        temp++;
        System.out.printf("%ds:(%d,%d)->(%d,%d)\n",temp,next_x,next_y,x,y);
        
 
        // 输出战斗过程
        while (blood[x][y] > 0)
        {
            temp++;
            System.out.printf("%ds:FIGHT AT (%d,%d)\n",temp,x,y);
            blood[x][y]--;
        }
    }
 
    public static void main(String[] args)
    {
        Scanner input = new Scanner(System.in);
 
        String str = new String();
        int result;
        while (input.hasNextInt())
        {
            n = input.nextInt();
            m = input.nextInt();
            input.nextLine();
 
            map = new int[n][m];
            flag = new int[n][m];
            blood = new int[n][m];
 
            for (int i=0;i

你可能感兴趣的:(杭电acm1026 Ignatius and the Princess I)