Pat(A) 1072. Gas Station (30)

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1072

1072. Gas Station (30)


A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 104), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format
P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:
4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2
Sample Output 1:
G1
2.0 3.3
Sample Input 2:
2 1 2 10
1 G1 9
2 G1 20
Sample Output 2:
No Solution

题目大意

给出给出N个房屋和M个加油站,共有K条路线表示其中之间的距离,加油站最长供应DS距离
输入第一行给出N M K Ds ,后K行给出两个点之间的距离,点可以是房屋也可以是候选加油站。
输出要求,每一个加油站到所有房屋都有个距离,其中有个最短距离,选择一个使这个最短距离最长的加油站。如果这样的加油站有多个,选择据所有房屋的平均距离最短的那个,如果依然有多个,选择标号较小的那个。

解题报告

典型的最短路问题,对每个加油站进行Dijkstra求最短路,因候选加油站也要计算在内,故也在图里。把N个房屋标号为0-(N-1),M个加油站标号为N-(N+M-1)。
需要注意的是
1. 输出的内容第一行是加油站号,第二行是那个最短距离和平均距离。
1. 择优的选择方法

代码

#include "iostream"
#include "string"

using namespace std;
int N,M,K,D;
int map[1000 + 20][1000 + 20] = {-1};
int dist[1000 + 20];
int visited[1000 + 20];
int res = -1,cost1,min_dist = 0;

int getId(string s){
    if (s.find('G')!=-1){
        return N + stoi(string(s,1)) - 1;
    }
    return stoi(s) - 1;
}

void init(){
    cin>>N>>M>>K>>D;
    cost1 = N * (D + 1);
    int i,j;
    string s,e;
    int start,end;
    int dis;
    for (i = 0; i< M + N; i++){
        for (j = 0; j< M + N; j++){
            map[i][j] = D + 1;
        }
        map[i][i] = 0;
        dist[i] = D + 1;
    }
    for (i = 0; i < K; i++){
        cin>>s>>e>>dis;
        start = getId(s);
        end = getId(e);
        map[start][end] = map[end][start] = dis;
    }
}

void printMap(){
    int i,j;
    printf("0");
    for(i=0;iprintf("\t%d",i);
    }
    cout<for (i = 0; i< M + N; i++){
        printf("%d",i);
        for (j = 0; j< M + N; j++){
            cout<<"\t"<<map[i][j];
        }
        cout<void dijk(int x){
    int i,j;
    for (i = 0; i < M + N; i ++){
        dist[i] = D + 1;
        visited[i] = 0;
    }
    visited[x] = 1;
    dist[x] = 0;
    for (int count = 0; count < M + N - 1; count++) {
        int k = x,min_d = D + 1;
        for (j = 0; j < M + N; j ++){
            if(!visited[j] && min_d > dist[j]){
                k = j;
                min_d = dist[j];
            }
        }
        visited[k] = 1;
        for (int v = 0; v < M + N; v++)
            if (!visited[v] && map[k][v] && dist[k] != D + 1 && dist[k] + map[k][v] < dist[v])
                dist[v] = dist[k] + map[k][v];
    }
    int  tcost1 = 0,tmin_dist = D+1;
    for(i = 0; i < N; i ++){
        if(dist[i] > D)
            return ;
        else{
            tcost1 += dist[i];
            tmin_dist = min(tmin_dist,dist[i]);
        }
    }
    if(tmin_dist>min_dist || (tmin_dist==min_dist && tcost1return ;
}


int main(){
    init();
    //printMap();
    for(int i = N; i < M + N;i++){
        dijk(i);
    }
    if(res != -1){
        cout<<"G"<1<printf("%.1f %.1f\n",(double)min_dist,((double)cost1)/N);
    }else
        printf("No Solution\n");
    //system("pause");
}

你可能感兴趣的:(PAT甲级)