Abbreviation----Java实现

题目描述

As we know, we often use a short sequence of characters in place of some words with a very long name. For example, ACM is an abbreviation of “Association for Computing Machinery”.
 Now we are using an acronymic method to get the abbreviation. An acronym is generated from a long name by capitalizing the first letter of every word in the name and concatenating them together.There is an exception: some words are ignored when generating the abbreviation. These words(case insensitively) meet the following rules:
 1. The common words “and”,“for”,and “the”.
 2. The words with length less than 3, such as “a”,“of”,“to”.
Your job is to get the abbreviation of a given string by using the acronymic method.

输入描述

The first line of the input is a positive integer T. T is the number of test cases followed. Each test case contains a string S with its length no greater than 100, representing the sequence of words to be abbreviated. The words consist of only alphabetic letter. There is only one space between the words, and there is no leading or trailing spaces in the string.

输出描述

For each test case, output the abbreviation of S.

样例输入

5
netease
The Lord of the Rings
North Eastern University at Qinhuangdao
Institute of Electrical and Electronics Engineers
Association for Computing Machinery

样例输出
N
LR
NEUQ
IEEE
ACM

import java.util.Scanner;

public class Main {
     

	public static void main(String args[]) {
     
		Scanner se=new Scanner(System.in);
		int n=Integer.parseInt(se.nextLine());
		for(int i=0;i<n;i++) {
     
			String s=se.nextLine();
			String str[]=s.split("\\s+");
			String a="";
			for(int j=0;j<str.length;j++) {
     
				str[j]=str[j].toUpperCase();
				if(str[j].length()>2 & !str[j].equals("AND")& !str[j].equals("THE")& !str[j].equals("FOR")) {
     
					String ae=String.valueOf(str[j].charAt(0));
					a=a.concat(ae);
				}
			}
			System.out.println(a);
		}
	}
}

你可能感兴趣的:(Abbreviation----Java实现)