顺序表的建立及遍历

读入n值及n个整数,建立顺序表并遍历输出。
输入格式:
读入n及n个整数
输出格式:
输出n个整数,以空格分隔(最后一个数的后面没有空格)。

输入样例:

4
-3 10 20 78

输出样例:

-3 10 20 78

代码

#include <stdio.h>
#include <stdlib.h>
#include<algorithm>
using namespace std;
#define MAXSIZE 100
typedef int ElemType;/*宏定义int型*/
typedef struct
{
     
    ElemType *elem;
    int length;
} SqList;
int n;
void InitList(SqList &L,int n)
{
     
    L.elem=(ElemType*)malloc(sizeof(MAXSIZE));/*开辟空间:(数据类型*)malloc(长度)*/
    L.length=0;
    ElemType q;
    for(int i=0; i<n; i++)
    {
     
        scanf("%d",&q);
        L.elem[L.length++]=q;
    }
    for(int i=0; i<L.length; i++)
        printf("%d%c",L.elem[i],i==L.length-1?'\n':' ');
    return;
}
int main()
{
     
    scanf("%d",&n);
    SqList L;
    InitList(L,n);
    return 0;
}
#include <stdio.h>
#include <stdlib.h>
#include <stdlib.h>
#include <malloc.h>
#include<algorithm>
using namespace std;
#define MAXSIZE 100
typedef int ElemType;/*宏定义int型*/
typedef struct
{
     
    ElemType elem[MAXSIZE];
    int last;
} SqList,*List;
int n;
void InitList(List &L,int n)
{
     
    L=(SqList*)malloc(sizeof(SqList));
    L->last=n-1;
    for(int i=0; i<=L->last; i++)
    {
     
        scanf("%d",&L->elem[i]);
    }
    for(int i=0; i<=L->last; i++)
        printf("%d%c",L->elem[i],i==L->last?'\n':' ');
}
int main()
{
     
    scanf("%d",&n);
    List L;/*List为结构体指针*/
    InitList(L,n);
    return 0;
}

你可能感兴趣的:(数据结构)