数据结构练习 00-自测4. Have Fun with Numbers (20)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes

2469135798
#include<iostream>

#include<string>

#include <sstream>

using namespace std;

int sort(int a[],int n){

    int temp;

    for(int i=0;i<n;i++){

        for(int j=i;j<n;j++){

            if(a[i]>a[j]){

                temp=a[i];

                a[i]=a[j];

                a[j]=temp;

            }

        }        

    }

    return 0;

}

int main(){

    string num;

    stringstream ss;

    int size,j=0;

    cin>>num;

    size=num.size();

    int *a=new int[size];

    int *b=new int[size+1];

    int *doubleNum=new int[size+1];

    for(int i=0;i<size+1;i++){

        doubleNum[i]=0;

        b[i]=0;

    }

    for(int i=0;i<size;i++){

        a[i]=num[i]-48;

    }

    for(int i=size;i>0;i--){

        if(a[i-1]+a[i-1]>=10){

            doubleNum[i]+=(a[i-1]+a[i-1])%10;

            doubleNum[i-1]+=1;

        }else{

            doubleNum[i]+=a[i-1]+a[i-1];    

        }            

    }

    if(doubleNum[0]==0){

        for(int i=0;i<size;i++){

            b[i+1]=doubleNum[i+1];

        }

        sort(doubleNum,size+1);

        sort(a,size);

        for(int i=0;i<size;i++){

        if(a[i]==doubleNum[i+1]){

            j++;

        }

        }

        if(j==size){

            cout<<"Yes"<<endl;

            for(int i=0;i<size;i++){

                cout<<b[i+1];

            }



        }else{

            cout<<"No"<<endl;

            for(int i=0;i<size;i++){

                cout<<b[i+1];

            }



        }

    }else{

        cout<<"No"<<endl;

        for(int i=0;i<size+1;i++){

            cout<<doubleNum[i];

        }

    }

        

}
测试
结果
image
 

你可能感兴趣的:(number)