PAT 1001 A+B Format (Python 实现)

题目:
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10
​6
​​ ≤a,b≤10
​6
​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

代码:

a, b = map(int, input().split())
y=a+b
l=str(abs(y))
sign = '' if y >= 0 else '-'
if abs(y)<1000:
    print(y)
else:
    print(sign,end="")
    for x in range(len(l)):
        print(l[x],end="")
        if (len(l)-x)%3==1 and x!=len(l)-1:
            print(',',end="")
a, b = map(int, input().split())
print(format(a+b,','))

你可能感兴趣的:(PAT)