OSPF(Open Shortest Path First,开放式最短路径优先协议) 基于SPF(最短路径算法)所开发,是一个标准的链路状态型路由协议,路由与路由间所传为拓扑状态,无类别协议,更新时携带子网掩码;组播更新224.0.0.5/6。但是需要结构化部署(区域划分、地址规划)区域内传拓扑,区域间传路由。
LSA(link-state advertisement)链路状态广播
ospf的七个状态机:
起初本地为down状态,一旦本地发出hello包就进入lnit初始化;接收到hello包后,若存在本地的RID,则进入2way状态;2way双向通信标志着邻居关系的建立(条件匹配:点到点网络直接进入下一状态,MA网络将进行DR/BDR的选举 DRother不得进入下一状态)Exstart预启动:发送类hello的DBD包进行主从关系的选举,RID数字大的为主优先进入Exchange准交换状态;准交换状态使用真正的DBD包进行数据库目录的共享,需要ack来进行确认,确认完毕进入Loading加载状态;加载状态使用LSR/LSU/LSack来获取未知的lsa信息,获取完毕进入full转发状态;转发状态标志着邻接关系的建立
DR指定一个路由器,BDR是指一个备份指定路由器。为减小多路访问网络中OSPF流量,OSPF会选择一个指定路由器(DR)和一个备份指定路由器(BDR)。当MA(多路访问)网络发生变化时,DR负责更新其他所有OSPF路由器。BDR会监控DR 的状态,并在当前DR发生故障时接替其角色 DR的选举规则:1.比较接口优先级,0-255 大的为优,默认为1 2.若接口优先级相同则比较RID
ospf的划分区域规则:必须为星型结构,区域0为骨干。
管理距离为110,优先级为10,度量为cost值=开销值=参考带宽/接口带宽,默认参考带宽为100M;整段路径cost值之和最小为最佳路径。
路由器插NM-4A/S的板卡
实验要求:全网可达,ro,r2-r4各存在一个环回。
配置:
R0:
R0(config)#interface lo0
R0(config-if)#ip address 172.16.1.1 255.255.255.0
R0(config-if)#ex
R0(config)#interface s1/0
R0(config-if)#ip address 192.168.1.1 255.255.255.0
R0(config-if)#no shutdown
R0(config-if)#ex
R0(config)#router ospf 1 启动时需要配置进程号,仅具有本地意义
R0(config-router)#router-id 1.1.1.1 配置RID,要求全网唯一
R0(config-router)#network 172.16.1.0 0.0.0.255 area 1 宣告用反掩码进行宣告 须写明区域
R0(config-router)#network 192.168.1.0 0.0.0.255 area 1
R1:
R1(config)#interface s1/0
R1(config-if)#ip address 192.168.1.2 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#ex
R1(config)#interface f0/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#ex
R1(config)#router ospf 1
R1(config-router)#router-id 2.2.2.2
R1(config-router)#network 192.168.1.0 0.0.0.255 area 1
R1(config-router)#network 192.168.2.0 0.0.0.255 area 0
R2:
R2(config)#interface f0/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#ex
R2(config)#interface lo0
R2(config-if)#ip address 172.16.2.1 255.255.255.0
R2(config-if)#ex
R2(config)#interface s1/0
R2(config-if)#ip address 1.1.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#ex
R2(config)#router ospf 1
R2(config-router)#router-id 3.3.3.3
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
R2(config-router)#network 172.16.2.0 0.0.0.255 area 2
R2(config-router)#network 1.0.0.0 0.0.0.255 area 2
R3:
R3(config)#interface f0/0
R3(config-if)#ip address 192.168.2.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#ex
R3(config)#interface lo0
R3(config-if)#ip address 172.16.3.1 255.255.255.0
R3(config-if)#ex
R3(config)#interface s1/0
R3(config-if)#ip address 1.1.1.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#ex
R3(config)#interface s1/1
R3(config-if)#ip address 2.2.2.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#ex
R3(config)#router ospf 1
R3(config-router)#router-id 4.4.4.4
R3(config-router)#network 192.168.2.0 0.0.0.255 area 0
R3(config-router)#network 172.16.3.0 0.0.0.255 area 2
R3(config-router)#network 1.0.0.0 0.0.0.255 area 2
R3(config-router)#network 2.0.0.0 0.0.0.255 area 2
R4:
R4(config)#interface f0/0
R4(config-if)#ip address 192.168.2.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#ex
R4(config)#interface s1/0
R4(config-if)#ip address 2.2.2.2 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#ex
R4(config)#interface lo0
R4(config-if)#ip address 172.16.4.1 255.255.255.0
R4(config-if)#ex
R4(config)#router ospf 1
R4(config-router)#router-id 5.5.5.5
R4(config-router)#network 192.168.2.0 0.0.0.255 area 0
R4(config-router)#network 172.16.4.0 0.0.0.255 area 2
R4(config-router)#network 2.0.0.0 0.0.0.255 area 2
测试连通性:
R0#ping 172.16.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/14 ms