快速切题 poj1068

Parencodings
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 19716   Accepted: 11910

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 

S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2

6

4 5 6 6 6 6

9 

4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6

1 1 2 4 5 1 1 3 9
题目大意:给你一组匹配的左右括号,定义序列P是第i个右括号前面的左括号数,定义序列W是第i个右括号到与它匹配的左括号中间的右括号(包括这个括号自身)的个数,已知P,求W
解题思路:定义ind数组分别表示第i个括号是第k个左/右括号,定义l数组表示第i个左括号前面有多少个右括号,r数组则是表示第i个右括号前面有多少个左括号,相减即可,对于括号匹配直接用的遍历,这题n如果是10e9就会有趣很多,这个时候右括号一定是匹配未被用到的最大值,也就是说其实不用遍历

应用时:5min
实际用时: 41min(读题太差)
#include<cstdio>

#include <cstring>

using namespace std;

int ind[45];

bool used[45];

int r[21];

int l[21];

int len,n,llen;

int w[21];

int main(){

    int t;

    scanf("%d",&t);

    while(t--){

        memset(used,0,sizeof(used));

        len=0,llen=0;

        scanf("%d",&n);

        for(int i=0;i<n;i++){

            scanf("%d",r+i);

            for(int j=0;j<r[i]-(i>0?r[i-1]:0);j++){

                ind[len++]=llen;

                l[llen++]=i;

            }

            ind[len++]=i;

        }

        for(int i=0;i<n;i++){

            int tind=r[i]+i;

            used[tind]=true;

            for(int j=tind-1;j>=0;j--){

                if(!used[j]){

                    w[i]=i-l[ind[j]]+1;

                    used[j]=true;

                    break;

                }

            }

        }

        for(int i=0;i<n;i++)printf("%d%c",w[i],i==n-1?'\n':' ');

    }

    return 0;

}

 

你可能感兴趣的:(poj)