POJ2406

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 23530   Accepted: 9880

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd

aaaa

ababab

.

Sample Output

1

4

3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

 
#include <cstdio>

#include <cstring>



using namespace std;



char str[1000010];

int next[1000010];



int main()

{

    int i,j;

    int len;

    int ans;



    while(scanf("%s",str)!=EOF)

    {

        if(!strcmp(str,"."))

            break;

        memset(next,0,sizeof(next));

        //kmp -- getNext()

        i=-1;

        j=0;

        len=strlen(str);

        next[0]=-1;

        while(j<len)

        {

            if(i==-1 || str[i]==str[j])

            {

                i++;

                j++;

                next[j]=i;

            }

            else

            {

                i=next[i];

            }

        }



        ans=1;

        i=len-next[len];

        if(len%i==0)

        {

            ans=len/i;

        }

        printf("%d\n",ans);

    }

    return 0;

}

 

你可能感兴趣的:(poj)