PAT甲级1001-Python

1001 A+B Format

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10e6≤a,b≤10e6 . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

提交结果

PAT甲级1001-Python_第1张图片
image.png

代码

if __name__=="__main__":
    line = input().split(" ")
    a,b = int(line[0]),int(line[1])
    print("{:,}".format(a+b))

积累

Python字符串的格式化函数,自己以后还要多积累多使用。
菜鸟教程

你可能感兴趣的:(PAT甲级1001-Python)