HDU 1689 线段树

http://acm.hdu.edu.cn/showproblem.php?pid=1698

Just a Hook
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7385 Accepted Submission(s): 3547

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input
1
10
2
1 5 2
5 9 3

Sample Output
Case 1: The total value of the hook is 24. 

  

#include <iostream>
using namespace std;

const int MAX_SIZE=100005;
const int DEFAULT_VALUE=1;

typedef struct
{
int value;
int left,right;
}Node;

Node tree[MAX_SIZE*3]; //一般设为3*N,有时要设到4*N

void Build(int root,int left,int right)
{
tree[root].left=left;
tree[root].right=right;
tree[root].value=DEFAULT_VALUE;
if(left==right)
return ;
int mid=(left+right)/2;
Build(root*2,left,mid);
Build(root*2+1,mid+1,right);
}

void Update(int root,int left,int right,int value)
{
if(tree[root].value==value)
return ;

//如果修改的区域一样
if(tree[root].left==left && tree[root].right==right)
{
tree[root].value=value;
return ;
}

// -1表示颜色是杂色,如果修改区域不一样,则先将其子区域
// 置为父值,对子区域进行操作
if(tree[root].value!=-1)
{
tree[2*root].value=
tree[root*2+1].value=tree[root].value;
tree[root].value=-1; //标记为杂色
}

int mid=(tree[root].left+tree[root].right)/2;
//如果更新区域在右边
if(left>mid)
Update(2*root+1,left,right,value);
//如果更细区域在左边
else if(right<=mid)
Update(root*2,left,right,value);
else
{
Update(2*root,left,mid,value);
Update(2*root+1,mid+1,right,value);
}
}

//计算总值
int Calculate(int root)
{
//如果所有的stick的颜色都一样的话
if(tree[root].value!=-1)
return (tree[root].right-tree[root].left+1)*tree[root].value;
else
return Calculate(root*2)+Calculate(root*2+1);
}


int main()
{
int cases;
cin>>cases;
int count=1;

while(cases--)
{
int stickNumber,updateNumber;

cin>>stickNumber;
Build(1,1,stickNumber);

cin>>updateNumber;

while(updateNumber--)
{
int left,right,value;
cin>>left>>right>>value;
Update(1,left,right,value);
}
cout<<"Case "<<count++<<": The total value of the hook is "
<<Calculate(1)<<"."<<endl;
}
return 0;
}

你可能感兴趣的:(HDU)