HDU_ACM_A+B for Input-Output Practice (V)

Problem Description
Your task is to calculate the sum of some integers.
 
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
 
Sample Input
2
4 1 2 3 4
5 1 2 3 4 5
 
Sample Output
10
15

#include "stdio.h"
int main(){
	int i,j,k,sum=0;
	scanf("%d",&i);
	while(i){
		scanf("%d",&j);
		while(j){
			scanf("%d",&k);
			sum=sum+k;
			j--;
		}
		printf("%d\n",sum);
		sum=0;
		i--;
	}
	return 0;
}

如果有什么不正确或不合适的地方,希望大家能在评论里面指出~~~

你可能感兴趣的:(ACM成长之路,ACM,C语言,HDOJ)