1027. Colors in Mars (20) PAT

题目:http://pat.zju.edu.cn/contests/pat-a-practise/1027

简单题,考察十进制数和n进制数的转换和输出格式的控制。


 

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71

Sample Output
#123456


 


 

#include<iostream>

#include<string.h>

using namespace std;



char red[2];

char green[2];

char blue[2];



void change(int a,char color[2],int base)

{

	int i=0;

	do 

	{

		if( (a%base)<10 )

			color[i++] = ((a%base) + '0');

		else

			color[i++] = (a%base) + 'A' - 10;

		a /= base;

	} while (a != 0);

}



int main()

{

	memset(red,'0',sizeof(red));

	memset(green,'0',sizeof(green));

	memset(blue,'0',sizeof(blue));

	int base = 13;

    int a,b,c;

	int n;

	cin>>a>>b>>c;

	change(a,red,base);

	change(b,green,base);

	change(c,blue,base);

	cout<<"#";

    cout<<red[1]<<red[0];

	cout<<green[1]<<green[0];

	cout<<blue[1]<<blue[0]<<endl;



	return 0;

}




 

 

你可能感兴趣的:(color)