http://acm.hdu.edu.cn/showproblem.php?pid=1175
连连看
Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17604 Accepted Submission(s): 4571
Problem Description
“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。
Input
输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!
Output
每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。
Sample Input
3 4
1 2 3 4
0 0 0 0
4 3 2 1
4
1 1 3 4
1 1 2 4
1 1 3 3
2 1 2 4
3 4
0 1 4 3
0 2 4 1
0 0 0 0
2
1 1 2 4
1 3 2 3
0 0
Sample Output
YES
NO
NO
NO
NO
YES
这道题,使用BFS,写一个结构体,记录当前方向,(而不是通过我以前的方法,那个想法好SB)通过记录move数组的i,记录方向,方向改变,转角次数加1, 同时,这道题不使用普通的标记,因为它有可能回来走,和Hdu的1072 Nightmare 一样,都有可能往回走,这题设开始每个点的转角次数很大,下次遇到这个点时,如果他 的转角次数少了,才在走这个点,通过这样标记,减少时间和队列的占用空间
这里要学会灵活,聪明使用标记,也学会了转角。。。
代码
// hdu 1175 连连看
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <queue>
using namespace std;
int m, n, x1, y1, x2, y2, flag;
int map[1005][1005];
int vis[1005][1005];
int move[4][2] = {0, -1, 0, 1, -1, 0, 1, 0};
struct point
{
int x, y, fx, zj;
} st;
queue<point>q;
void bfs();
int main()
{
int i, j, t;
//freopen("1.txt","w",stdout);
while (~scanf("%d %d", &n, &m) && m + n != 0)
{
for (i = 1; i <= n; i++)
{
for (j = 1; j <= m; j++)
{
scanf("%d", &map[i][j]);
}
}
scanf("%d", &t);
for (i = 0; i < t; i++)
{
scanf("%d %d %d %d", &x1, &y1, &x2, &y2);
if ((map[x1][y1] == map[x2][y2]) && map[x1][y1] != 0)
{
for(int ii=1;ii<=n;ii++)
for(j=1;j<=m;j++)
vis[ii][j] = 1000;
st.x = x1; st.y = y1; st.fx = -1; st.zj = 0;
flag = 0;
bfs();
if (flag)
{
printf("YES\n");
}
else
{
printf("NO\n");
}
}
else
{
printf("NO\n");
}
}
}
}
void bfs()
{
while (!q.empty())
{
q.pop();
}
q.push(st);
while (!q.empty())
{
point now = q.front();
q.pop();
//printf("x=%d,y=%d,fx=%d,zj=%d\n",now.x,now.y,now.fx,now.zj);
if (now.x == x2 && now.y == y2)
{
flag = 1;
return;
}
for (int i = 0; i < 4; i++)
{
//printf("haha");
point next = now;
next.x = now.x + move[i][0];
next.y = now.y + move[i][1];
next.fx = i;
//printf("next %d %d %d %d\n",next.x,next.y,next.fx,next.zj);
if (now.fx != next.fx && now.fx != -1)
{
next.zj++;
}
if (next.x < 1 || next.y < 1 || next.x > n || next.y > m || next.zj > 2)
{
continue;
}
if (map[next.x][next.y]!=0 && !(next.x == x2 && next.y == y2))
{
continue;
}
if (next.zj < vis[next.x][next.y])
{
vis[next.x][next.y] = next.zj;
q.push(next);
}
}
}
}
以前的搓比代码(备用)
<pre name="code" class="cpp"> if (xx > 0 && xx <= n && yy > 0 && yy <= m && map[xx][yy] == 0 && now.f < 3 && !vis[xx][yy])
{
point next = now;
next.x = xx;
next.y = yy;
vis[xx][yy] = 1;
if (xx != a && yy != b)
{
a = xx;
b = yy;
next.f++;
}
q.push(next);
}
}
}
}