Hash和枚举 解决POJ 1840

 

Description

Consider equations having the following form: 
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654
 
 
  

 

用这个来做hash的入门是再好不过了

在网上也看到很有关hash的代码,但是

总是看不懂呀,心里老是不明白是怎么

一回事,自从看到这个代码之后,一下就

大悟了。哈哈。

 

View Code
View Code 



#include <iostream>

#include <cmath>

#define size  200005

using namespace std;



int hash[size][10],num[size];



int main()

{

    memset(num, 0, sizeof(num));

    int i,j,k,l;

    int count=0;

    int temp,mark;

    int a[5];

    scanf("%d%d%d%d%d",&a[0],&a[1],&a[2],&a[3],&a[4]);



    for(i=-50;i<=50;i++)

        for(j=-50;j<=50;j++){

            if(i!=0 && j!=0){

                temp=a[0]*i*i*i+a[1]*j*j*j;

                mark=abs(temp)%size;//设置key值

                hash[mark][num[mark]]=temp;//建立哈希表:mark为key信息,temp为要存储的信息

                num[mark]++;//防止冲突

            }

        }

    for(i=-50;i<=50;i++)

        for(j=-50;j<=50;j++)

            for(k=-50;k<=50;k++){

                if(i!=0 && j!=0 && k!=0){

                   temp=a[2]*i*i*i+a[3]*j*j*j+a[4]*k*k*k;

                    mark=abs(temp)%size;

                    for(l=0;l<num[mark];l++){ //匹配

                        if(temp==hash[mark][l])

                            count++;

                    }

                }

            }

    printf("%d\n",count);

    return 0;

}

 

 

 

 
  
 

你可能感兴趣的:(hash)