园区网络三层架构实验

第二天

        核心层设计:
            原则:
            ·性能
            ·容量
            ·扩展性
            ·可靠性
            架构设计:工作模式(是否支持堆叠),可靠性,部署方案
            上下行组网:上行接口宽带,链路类型
            设备选型:性能指标,设备推荐

核心的可靠性:
            可靠性:
            ·主控1:1
            ·组网的1:1,或者1+1
            ·电源DC1+1,AC1+1,2+2
            ·模块化风扇设计,独立风扇
            ·无缘背板,高可靠性
            ·所有模块支持热插拔
            ·设备管理1:1备份
        
        经典组网架构
            
            ·无环
            ·设备可靠性有保障——堆叠
            ·链路可靠性有保障——聚合
            ·配置简单,故障率低,管理与排错简单
        
        网关设计:
            网关设计决定园区网的二三层分界;
            理论上网关可以放在任何一层,具体放在那一层需要权衡网络性能和管理等诸多因素
            
            三层架构大中型园区推荐汇聚层,中小型园区推荐核心层
            二层架构推荐核心层
            
            推荐在汇聚层上做网关
            

实验

园区网络三层架构实验_第1张图片

 我们以区域2来主要配置

从接入层开始先划分vlan,分别为 11-12  13-14 15-16 17-18

vlan batch 11-19 
port-group group-member g0/0/3 to g0/0/10
	 port link-type access
	 port default vlan 11
 	 stp edged-port enable
port-group group-member g0/0/11 to g0/0/20
	port link-type access
	port default vlan 12
 	stp edged-port enable
port-group group-member g0/0/1 to g0/0/2
 port link-type trunk
 undo port trunk allow-pass vlan 1   
 port trunk allow-pass vlan 11 to 12

21 22 23只需要修改vlan数据,其余配置一致

汇聚层

        lsw14和lsw15进行聚合

interface Eth-Trunk34
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 11 to 19
 trunkport GigabitEthernet 0/0/3
 trunkport GigabitEthernet 0/0/4
-----------------------------------
interface Eth-Trunk34
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 11 to 19 
 trunkport GigabitEthernet 0/0/3
 trunkport GigabitEthernet 0/0/4

进行查看

园区网络三层架构实验_第2张图片

 让接入层和汇聚层设备连通

lsw14:

interface GigabitEthernet0/0/5
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 11 to 12

interface GigabitEthernet0/0/6
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 13 to 14
 
interface GigabitEthernet0/0/7
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 15 to 16
 
interface GigabitEthernet0/0/8
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 17 to 18

lsw15:

interface GigabitEthernet0/0/5
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 11 to 12

interface GigabitEthernet0/0/6
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 13 to 14
 
interface GigabitEthernet0/0/7
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 15 to 16
 
interface GigabitEthernet0/0/8
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 17 to 18

在汇聚层配置网关

lsw14

interface vlanif11
 ip address 192.168.11.1 24
 
interface Vlanif12
 ip address 192.168.12.1 24

interface Vlanif13
 ip address 192.168.13.1 24

interface Vlanif14
 ip address 192.168.14.1 24
 
interface Vlanif15
 ip address 192.168.15.1 24
 
interface Vlanif16
 ip address 192.168.16.1 24

interface Vlanif17
 ip address 192.168.17.1 24

interface Vlanif18
 ip address 192.168.18.1 24

lsw15

interface vlanif11
 ip address 192.168.11.2 24
 
interface Vlanif12
 ip address 192.168.12.2 24

interface Vlanif13
 ip address 192.168.13.2 24

interface Vlanif14
 ip address 192.168.14.2 24
 
interface Vlanif15
 ip address 192.168.15.2 24
 
interface Vlanif16
 ip address 192.168.16.2 24

interface Vlanif17
 ip address 192.168.17.2 24

interface Vlanif18
 ip address 192.168.18.2 24

配置汇聚层与核心层:

接下来,配置汇聚层与核心层部分:

在LSW14上创建vlan 40(LSW24) 和 vlan41(LSW10)
在LSW15上创建vlan 50(LSW24) 和 vlan51(LSW10)
LSW10和LSW24上再创建vlan100

lsw14

vlan batch 40 41
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 41

interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 40

interface Vlanif41
 ip address 10.0.41.1 255.255.255.0
 interface Vlanif40
 ip address 10.0.40.2 255.255.255.0

lsw15

vlan batch 50 51
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 50

interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 51

interface Vlanif50
 ip address 10.0.50.1 255.255.255.0
 interface Vlanif51
 ip address 10.0.51.2 255.255.255.0

lsw10

vlan batch 41 51 100
interface Eth-Trunk10
trunkport g0/0/23
trunkport g0/0/24
 port link-type trunk
 port trunk allow-pass vlan 100

interface GigabitEthernet0/0/5
 port link-type access
 port default vlan 41
 
interface GigabitEthernet0/0/6
 port link-type access
 port default vlan 51

interface Vlanif100
 ip address 10.0.100.1 255.255.255.0

interface Vlanif41
 ip address 10.0.41.1 255.255.255.0

interface Vlanif51
 ip address 10.0.51.1 255.255.255.0 

lsw24

vlan batch 40 50 100
interface Eth-Trunk10
trunkport g0/0/23
trunkport g0/0/24
 port link-type trunk
 port trunk allow-pass vlan 100

interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 40
 
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 50

interface Vlanif100
 ip address 10.0.100.1 255.255.255.0

interface Vlanif41
 ip address 10.0.40.1 255.255.255.0

interface Vlanif51
 ip address 10.0.50.1 255.255.255.0 

最后

LSW12和 LSW13以LSW10为主核心,以LSW24为备核心

LSW14和 LSW15以LSW24为主核心,以LSW10为备核心  

利用冗余协议(VRRP)进行配置,

lsw14

interface vlan11
 vrrp vrid 1 virtual-ip 192.168.11.1
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/1 reduced 15
 vrrp vrid 1 track interface GigabitEthernet0/0/2 reduced 15

interface Vlanif12
 vrrp vrid 1 virtual-ip 192.168.12.1
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/1 reduced 15
 vrrp vrid 1 track interface GigabitEthernet0/0/2 reduced 15

interface vlan13
 vrrp vrid 1 virtual-ip 192.168.13.1
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/1 reduced 15
 vrrp vrid 1 track interface GigabitEthernet0/0/2 reduced 15

interface vlan14
 vrrp vrid 1 virtual-ip 192.168.14.1
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/1 reduced 15
 vrrp vrid 1 track interface GigabitEthernet0/0/2 reduced 15

interface vlan15
 vrrp vrid 1 virtual-ip 192.168.15.1
 vrrp vrid 1 authentication-mode md5 123456

interface vlan16
 vrrp vrid 1 virtual-ip 192.167.16.1

interface vlan17
 vrrp vrid 1 virtual-ip 192.167.17.1

interface vlan18
 vrrp vrid 1 virtual-ip 192.167.18.1


lsw15

interface vlanif11
 vrrp vrid 1 virtual-ip 192.168.11.2

interface Vlanif12
 vrrp vrid 1 virtual-ip 192.168.12.2

interface vlan13
 vrrp vrid 1 virtual-ip 192.168.13.2

interface vlan14
 vrrp vrid 1 virtual-ip 192.168.14.2

interface vlan15
 vrrp vrid 1 virtual-ip 192.168.15.2
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/1 reduced 15
 vrrp vrid 1 track interface GigabitEthernet0/0/2 reduced 15

interface vlan16
 vrrp vrid 1 virtual-ip 192.167.16.2
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/1 reduced 15
 vrrp vrid 1 track interface GigabitEthernet0/0/2 reduced 15

interface vlan17
 vrrp vrid 1 virtual-ip 192.167.17.2
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/1 reduced 15
 vrrp vrid 1 track interface GigabitEthernet0/0/2 reduced 15

interface vlan18
 vrrp vrid 1 virtual-ip 192.167.18.2
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/1 reduced 15
 vrrp vrid 1 track interface GigabitEthernet0/0/2 reduced 15

你可能感兴趣的:(网络安全,网络协议)