Kruskal——畅通工程1

Description

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。 
 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N 
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。 
 

Output

对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。 
 

Sample Input

3 3 1 2 1 1 3 2 2 3 4 1 3 2 3 2 0 100
 

Sample Output

3 ?
 大意:与前面畅通工程异曲同工只是在判断是否收入的时候用一个num来标记,如果num的数目小于循环的数目那么说明此路不通,与floyed算法里的用a数组来标记很像,见  Stockbroker Grapevine

 

#include<cstdio>

#include<cstring>

#include<algorithm>

using namespace std;

const int MAX = 5000;

struct edge{

    int s;

    int e;

    int w;

}a[MAX];

bool cmp(edge a,edge b){

    return a.w < b.w;

}

int p[MAX];

int find(int x){

 return x == p[x]?x:p[x] = find(p[x]);

 }

 int main()

 {

     int N,M;

     while(~scanf("%d",&N)&&N){

            M = N*(N-1)/2;

          memset(p,0,sizeof(p));

          memset(a,0,sizeof(a));

          for(int i = 1; i <= N;i++)

             p[i] = i;

          for(int i = 1 ; i<= M;i++)

            scanf("%d%d%d",&a[i].s,&a[i].e,&a[i].w);

          sort(a+1,a+M+1,cmp);

          int sum = 0;

          for(int i = 1;i <= M ;i++){

                int fx = find(a[i].s),fy = find(a[i].e);

           if(fx!=fy){

            p[fx] = fy;

           sum +=a[i].w;

            }

        }

        printf("%d\n",sum);

     }

     return 0;

 }
View Code

 

你可能感兴趣的:(r)