ISATAP隧道配置与验证
【实验目的】
熟悉IPv6ISATAP隧道的概念。
掌握IPv6和IPv4共存的实现方法。
掌握IPv6 ISATAP地址编址规则。
掌握IPv6 ISATAP隧道的配置。
验证配置。
【实验拓扑】
设备参数如下表所示。
设备 |
接口 |
IP地址 |
子网掩码 |
默认网关 |
R1 |
S0/0 |
192.168.12.1 |
24 |
N/A |
Loopback 0 |
2000:F106:F208:1::1 |
64 |
N/A |
|
Tunnel0 |
2000:f106:f208:12:: |
64(eui-64) |
NA/A |
|
R2 |
S0/0 |
192.168.12.2 |
24 |
N/A |
Loopback 0 |
2000:F106:F208:2::1 |
64 |
N/A |
|
Tunnel0 |
2000:f106:f208:12:: |
64(eui-64) |
NA/A |
实验脚本:
//R1
interface Serial0/0
ip address 192.168.12.1 255.255.255.0
clock rate 2000000
no shutdown
interface Loopback0
ipv6 address 2000:F106:F208:1::1/64
ipv6 enable
no shutdown
interface Tunnel0
ipv6 address 2000:f106:f208:12::/64 eui-64
ipv6 enable
tunnel source Serial0/0
tunnel mode ipv6ip isatap
exit
do show ipv6 int b
ipv6 route 2000:F106:F208:2::/64 Tunnel0 2000:F106:F208:12:0:5EFE:C0A8:C02
end
write
//R2
interface Serial0/0
ip address 192.168.12.2 255.255.255.0
clock rate 2000000
no shutdown
interface Loopback0
ipv6 address 2000:F106:F208:2::1/64
ipv6 enable
no shutdown
interface Tunnel0
ipv6 address 2000:f106:f208:12::/64 eui-64
ipv6 enable
tunnel source Serial0/0
tunnel mode ipv6ip isatap
exit
do show ipv6 int b
ipv6 route 2000:F106:F208:1::/64 Tunnel0 2000:f106:f208:12::
end
write
【实验调试】
R1#show interfaces tunnel 0
Tunnel0 is up, line protocol is up
Hardware is Tunnel
MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel source 192.168.12.1 (Serial0/0), destination UNKNOWN
Tunnel protocol/transport IPv6 ISATAP
Fast tunneling enabled
Tunnel transmit bandwidth 8000 (kbps)
Tunnel receive bandwidth 8000 (kbps)
Last input never, output 00:02:16, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
12 packets output, 1152 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
R1#
R1#show ipv6 interface tunnel 0
Tunnel0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::5EFE:C0A8:C01
Global unicast address(es):
2000:F106:F208:12:0:5EFE:C0A8:C01, subnet is 2000:F106:F208:12::/64 [EUI]
Joined group address(es):
FF02::1
FF02::2
FF02::1:FFA8:C01
MTU is 1480 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is not supported
ND reachable time is 30000 milliseconds
R1#
R1#ping ipv6 2000:F106:F208:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:F106:F208:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/16/20 ms
R1#
R2#ping ipv6 2000:F106:F208:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:F106:F208:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms
R2#
【实验详解】
1.熟悉IPv6 ISATAP隧道的概念:
2.掌握IPv6和IPv4共存的实现方法:
3.掌握IPv6 ISATAP地址编址规则:
4.掌握IPv6 ISATAP隧道的配置:
5.验证配置:
通过完成这个实验,你将对ISATAP隧道有更深入的了解,并能够配置和验证ISATAP隧道的功能和互通性。
【复习巩固】
当进行ISATAP隧道配置实验时,以下是每个知识点的详细解释,并附带例子说明:
1.IPv6基础知识:
2.IPv4和IPv6共存:
3.ISATAP隧道概念:
4.ISATAP隧道配置:
interface Tunnel0
tunnel source Serial0/0
tunnel mode ipv6ip isatap
interface Tunnel0
tunnel source Serial0/0
tunnel mode ipv6ip isatap
5.路由配置:
ipv6 route 2000:F106:F208:2::/64 Tunnel0 2000:F106:F208:12:0:5EFE:C0A8:C02
ipv6 route 2000:F106:F208:1::/64 Tunnel0 2000:F106:F208:12::
6.配置验证和故障排除:
show interfaces tunnel 0
show ipv6 interface tunnel 0
show ipv6 interface tunnel 0
ping ipv6 2000:F106:F208:2::1
ping ipv6 2000:F106:F208:1::1
通过掌握这些知识点和实验中的例子,您将能够理解ISATAP隧道的概念、IPv4和IPv6共存的方法、隧道配置和路由配置的步骤,以及验证和故障排除的技巧。这些知识将帮助您成功完成ISATAP隧道配置实验并加深对相关概念和技术的理解。